summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/video.scm9
1 files changed, 1 insertions, 8 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 5d118ca32d..dcefd4ee0d 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -755,14 +755,7 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
           'configure 'setup-waf
           (lambda* (#:key inputs #:allow-other-keys)
             (copy-file (assoc-ref inputs "waf") "waf")
-            (setenv "CC" "gcc")))
-         (add-before
-          'configure 'patch-wscript
-          (lambda* (#:key inputs #:allow-other-keys)
-            (substitute* "wscript"
-              ;; XXX Remove this when our Samba package provides a .pc file.
-              (("check_pkg_config\\('smbclient'\\)")
-               "check_cc(lib='smbclient')")))))
+            (setenv "CC" "gcc"))))
        ;; No check function defined.
        #:tests? #f))
     (home-page "http://mpv.io/")