summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/audio.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 68cea0a693..18982b7257 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3356,11 +3356,17 @@ code, used in @code{libtoxcore}.")
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "tst"
-       #:make-flags '("INSTALL_ROOT=%output"
-                      "CCFLAGS=-fPIC \
--c -O2 -DNeedFunctionPrototypes=1 -Wall -Wno-comment") ;default options
+       #:make-flags (list (string-append "INSTALL_ROOT=" %output))
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'add-fpic-ccflag
+           (lambda _
+             ;; The -fPIC compiler option is needed when building
+             ;; mediastreamer.
+             (substitute* "Makefile"
+               (("^CCFLAGS.*" all)
+                (string-append all "CCFLAGS += -fPIC")))
+             #t))
          (add-before 'install 'pre-install
            (lambda _
              (let ((out (assoc-ref %outputs "out")))