summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/sagemath.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index dd8c062d31..06c4c0a17d 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -22,6 +22,7 @@
   #:use-module (guix download)
   #:use-module (guix build-system python)
   #:use-module (gnu packages algebra)
+  #:use-module (gnu packages compression)
   #:use-module (gnu packages multiprecision)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz))
@@ -58,3 +59,33 @@ but it can be used independently.")
 (define-public python2-cypari2
   (package-with-python2 python-cypari2))
 
+;; The stable version of the following package is not young enough to be
+;; used with Sage, since it does not support cython. One would need to
+;; use an alpha release. On the other hand, Sage can be built without it.
+(define-public python-gmpy2
+  (package
+   (name "python-gmpy2")
+   (version "2.0.8")
+   (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "gmpy2" version ".zip"))
+       (sha256
+         (base32
+           "0grx6zmi99iaslm07w6c2aqpnmbkgrxcqjrqpfq223xri0r3w8yx"))))
+   (build-system python-build-system)
+   (native-inputs
+      `(("unzip" ,unzip)))
+   (inputs
+      `(("gmp" ,gmp)
+        ("mpfr" ,mpfr)
+        ("mpc" ,mpc)))
+   (home-page "https://github.com/aleaxit/gmpy")
+   (synopsis
+     "GMP/MPIR, MPFR, and MPC interface to Python 2.6+ and 3.x")
+   (description
+     "GMP/MPIR, MPFR, and MPC interface to Python 2.6+ and 3.x")
+   (license #f)))
+
+(define-public python2-gmpy2
+  (package-with-python2 python-gmpy2))