summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/tex.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d0f634ad01..3d54a1e863 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4441,6 +4441,23 @@ means to select single glyphs from symbol fonts.  The bundle as a whole is
 part of the LaTeX required set of packages.")
       (license license:lppl1.2+))))
 
+(define-public texlive-psnfss/fixed
+  (package
+    (inherit texlive-psnfss)
+    (name "texlive-psnfss-fixed")
+    (arguments
+     (substitute-keyword-arguments (package-arguments texlive-psnfss)
+       ((#:phases phases)
+        `(modify-phases ,phases
+           (add-before 'copy-files 'unchdir
+             (lambda _
+               (chdir "../../..")))
+           (add-after 'copy-files 'delete-extra-files
+             (lambda* (#:key outputs #:allow-other-keys)
+               (delete-file-recursively
+                (string-append (assoc-ref outputs "out")
+                               "/share/texmf-dist/source/latex/psnfss/build"))))))))))
+
 (define-deprecated-package texlive-latex-psnfss texlive-psnfss)
 
 ;; For user profiles