summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/openssh-hurd.patch30
-rw-r--r--gnu/packages/ssh.scm19
3 files changed, 9 insertions, 41 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 1fc37ca6e8..f2ae61f108 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1684,7 +1684,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/openjdk-15-xcursor-no-dynamic.patch	\
   %D%/packages/patches/openmpi-mtl-priorities.patch		\
   %D%/packages/patches/openmw-assume-nonconst-SIGSTKSZ.patch    \
-  %D%/packages/patches/openssh-hurd.patch			\
   %D%/packages/patches/openssh-trust-guix-store-directory.patch	\
   %D%/packages/patches/openresolv-restartcmd-guix.patch	\
   %D%/packages/patches/openrgb-unbundle-hueplusplus.patch	\
diff --git a/gnu/packages/patches/openssh-hurd.patch b/gnu/packages/patches/openssh-hurd.patch
deleted file mode 100644
index 1ad09a7ee6..0000000000
--- a/gnu/packages/patches/openssh-hurd.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Author: Jan (janneke) Nieuwenhuizen" <janneke@gnu.org>
-Not upstreamed.
-
-From 1ddae040d67e9a4ebcc3e1b95af1bff12c0f086b Mon Sep 17 00:00:00 2001
-From: "Jan (janneke) Nieuwenhuizen" <janneke@gnu.org>
-Date: Tue, 7 Apr 2020 17:41:05 +0200
-Subject: [PATCH] Build fix for the Hurd.
-
-* gss-serv.c (ssh_gssapi_acquire_cred): Use HOST_NAME_MAX instead of
-MAXHOSTNAMELEN.
----
- gss-serv.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/gss-serv.c b/gss-serv.c
-index 1d47870e7..22081c6f1 100644
---- a/gss-serv.c
-+++ b/gss-serv.c
-@@ -107,7 +107,7 @@ ssh_gssapi_acquire_cred(Gssctxt *ctx)
- 		gss_create_empty_oid_set(&status, &oidset);
- 		gss_add_oid_set_member(&status, ctx->oid, &oidset);
- 
--		if (gethostname(lname, MAXHOSTNAMELEN)) {
-+		if (gethostname(lname, HOST_NAME_MAX)) {
- 			gss_release_oid_set(&status, &oidset);
- 			return (-1);
- 		}
--- 
-2.26.0
-
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 81fbfd87a1..3a5d5ef59b 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -198,16 +198,15 @@ a server that supports the SSH-2 protocol.")
 (define-public openssh
   (package
    (name "openssh")
-   (version "9.3p2")
-   (source (origin
-             (method url-fetch)
-             (uri (string-append "mirror://openbsd/OpenSSH/portable/"
-                                 "openssh-" version ".tar.gz"))
-             (patches (search-patches "openssh-hurd.patch"
-                                      "openssh-trust-guix-store-directory.patch"))
-             (sha256
-              (base32
-               "1s3nqv57r3l7avsdkzwd575dvxra8h19xpqczl0z3cvcgwabw3i0"))))
+   (version "9.4p1")
+   (source
+    (origin
+      (method url-fetch)
+      (uri (string-append "mirror://openbsd/OpenSSH/portable/"
+                          "openssh-" version ".tar.gz"))
+      (patches (search-patches "openssh-trust-guix-store-directory.patch"))
+      (sha256
+       (base32 "11bahrik5qi337m954g5479f63cxnxdch076ng7668fvi28gs21n"))))
    (build-system gnu-build-system)
    (arguments
     (list