summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm31
1 files changed, 23 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1abb1c8c87..8b85631318 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -47629,8 +47629,30 @@ platform-native strings.")
      "This package provides a ttf-parser plus support for owned data.")
     (license license:asl2.0)))
 
+(define-public rust-owo-colors-4
+  (package
+    (name "rust-owo-colors")
+    (version "4.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "owo-colors" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0grsk47cllj0s4nc4qxvy4gdhj2lyiglbqx4lmw2m7grdmq59zya"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-supports-color" ,rust-supports-color-2))))
+    (home-page "https://github.com/jam1garner/owo-colors")
+    (synopsis "Zero-allocation terminal colors that'll make people go owo")
+    (description
+     "This package provides zero-allocation terminal colors that'll make people go
+owo.")
+    (license license:expat)))
+
 (define-public rust-owo-colors-3
   (package
+    (inherit rust-owo-colors-4)
     (name "rust-owo-colors")
     (version "3.6.0")
     (source (origin
@@ -47639,14 +47661,7 @@ platform-native strings.")
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "0943lynkwz1glq3w7m9anv73lnrhd8yabs09krbh49g1wz4lxp39"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs (("rust-supports-color" ,rust-supports-color-2))))
-    (home-page "https://github.com/jam1garner/owo-colors")
-    (synopsis "Zero-allocation terminal colors that'll make people go owo")
-    (description "Zero-allocation terminal colors that'll make people go owo")
-    (license license:expat)))
+                "0943lynkwz1glq3w7m9anv73lnrhd8yabs09krbh49g1wz4lxp39"))))))
 
 (define-public rust-owned-ttf-parser-0.6
   (package