summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/shells.scm36
1 files changed, 29 insertions, 7 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index cfbc4cd97e..29307bd8c6 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -22,6 +22,7 @@
 ;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
 ;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2023 David Pflug <david@pflug.io>
+;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
 ;;; Copyright © 2024 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -1036,8 +1037,35 @@ directory.  These values can be piped through a series of steps, in a series
 of commands called a ``pipeline''.")
     (license license:expat)))
 
+(define-public rust-nu-ansi-term-0.49
+  (package
+    (name "rust-nu-ansi-term")
+    (version "0.49.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "nu-ansi-term" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0s2svfnircd9jp06wk55qcbb9v5cadkfcjfg99vm21qdjg0x6wy0"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-serde" ,rust-serde-1)
+        ("rust-windows-sys" ,rust-windows-sys-0.48))
+       #:cargo-development-inputs
+       (("rust-doc-comment" ,rust-doc-comment-0.3)
+        ("rust-serde-json" ,rust-serde-json-1))))
+    (home-page "https://www.nushell.sh")
+    (synopsis "Library for ANSI terminal colors and styles (bold, underline)")
+    (description
+     "This package is a library for ANSI terminal colors and styles (bold,
+underline).")
+    (license license:expat)))
+
 (define-public rust-nu-ansi-term-0.44
   (package
+    (inherit rust-nu-ansi-term-0.49)
     (name "rust-nu-ansi-term")
     (version "0.44.0")
     (source
@@ -1054,13 +1082,7 @@ of commands called a ``pipeline''.")
        (("rust-doc-comment" ,rust-doc-comment-0.3)
         ("rust-overload" ,rust-overload-0.1)
         ("rust-serde" ,rust-serde-1)
-        ("rust-winapi" ,rust-winapi-0.3))))
-    (home-page "https://www.nushell.sh")
-    (synopsis "Library for ANSI terminal colors and styles (bold, underline)")
-    (description
-     "This package is a library for ANSI terminal colors and styles (bold,
-underline).")
-    (license license:expat)))
+        ("rust-winapi" ,rust-winapi-0.3))))))
 
 (define-public rust-nu-cli-0.44
   (package