summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ccache.scm36
1 files changed, 18 insertions, 18 deletions
diff --git a/gnu/packages/ccache.scm b/gnu/packages/ccache.scm
index a36de3af88..2923a998c8 100644
--- a/gnu/packages/ccache.scm
+++ b/gnu/packages/ccache.scm
@@ -20,6 +20,7 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages ccache)
+  #:use-module (guix gexp)
   #:use-module (guix packages)
   #:use-module ((guix licenses) #:select (gpl3+))
   #:use-module (guix download)
@@ -45,24 +46,23 @@
     (inputs (list zlib
                   `(,zstd "lib")))
     (arguments
-     '( ;; The Redis backend must be explicitly disabled to build without Redis.
-       #:configure-flags
-       '("-DREDIS_STORAGE_BACKEND=OFF")
-
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'configure 'fix-shell
-           ;; Run early whilst we're still in the source directory.
-           (lambda _
-             (substitute* (list "test/run"
-                                "test/suites/base.bash"
-                                "unittest/test_hashutil.cpp")
-               (("compgen -e") "env | cut -d= -f1")
-               (("#!/bin/sh") (string-append "#!" (which "sh"))))))
-         (add-before 'check 'set-home
-           ;; Tests require a writable HOME.
-           (lambda _
-             (setenv "HOME" (getenv "TMPDIR")))))))
+     (list #:configure-flags
+           ;; The backend must be explicitly disabled to build without Redis.
+           #~(list "-DREDIS_STORAGE_BACKEND=OFF")
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'configure 'fix-shell
+                 ;; Run early whilst we're still in the source directory.
+                 (lambda _
+                   (substitute* (list "test/run"
+                                      "test/suites/base.bash"
+                                      "unittest/test_hashutil.cpp")
+                     (("compgen -e") "env | cut -d= -f1")
+                     (("#!/bin/sh") (string-append "#!" (which "sh"))))))
+               (add-before 'check 'set-home
+                 ;; Tests require a writable HOME.
+                 (lambda _
+                   (setenv "HOME" (getenv "TMPDIR")))))))
     (home-page "https://ccache.dev/")
     (synopsis "Compiler cache")
     (description