summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4c6e8e63f0..61c29be116 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9805,3 +9805,32 @@ methods @code{MarshalJSON} and @code{UnmarshalJSON} unlike
 kubernetes-sigs/yaml is a permanent fork of
 @url{https://github.com/ghodss/yaml,ghodss/yaml}.")
     (license (list license:expat license:bsd-3))))
+
+(define-public go-github-com-google-go-jsonnet
+  (package
+    (name "go-github-com-google-go-jsonnet")
+    (version "0.18.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/google/go-jsonnet")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1dghqygag123zkgh2vrnq82cdag5z0p03v3489pwhs06r5g27wm3"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/google/go-jsonnet/cmd/jsonnet"
+       #:unpack-path "github.com/google/go-jsonnet"))
+    (propagated-inputs (list go-sigs-k8s-io-yaml go-gopkg-in-yaml-v2
+                             go-github-com-sergi-go-diff
+                             go-github-com-fatih-color))
+    (home-page "https://github.com/google/go-jsonnet")
+    (synopsis "Go implementation of Jsonnet")
+    (description
+     "This package provides an implementation of the @url{http://jsonnet.org/,
+Jsonnet} data templating language in Go.  It is a feature-complete,
+production-ready implementation, compatible with the original Jsonnet C++
+implementation.")
+    (license license:asl2.0)))