summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--guix/build-system/cmake.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/guix/build-system/cmake.scm b/guix/build-system/cmake.scm
index 2bcc8ac046..0b8a651ee0 100644
--- a/guix/build-system/cmake.scm
+++ b/guix/build-system/cmake.scm
@@ -116,6 +116,7 @@
                       (imported-modules %cmake-build-system-modules)
                       (modules '((guix build cmake-build-system)
                                  (guix build utils)))
+                      allowed-references
                       disallowed-references)
   "Build SOURCE using CMAKE, and with INPUTS. This assumes that SOURCE
 provides a 'CMakeLists.txt' file as its build system."
@@ -158,6 +159,7 @@ provides a 'CMakeLists.txt' file as its build system."
                       #:target #f
                       #:graft? #f
                       #:substitutable? substitutable?
+                      #:allowed-references allowed-references
                       #:disallowed-references disallowed-references
                       #:guile-for-build guile)))
 
@@ -193,6 +195,7 @@ provides a 'CMakeLists.txt' file as its build system."
                             (imported-modules %cmake-build-system-modules)
                             (modules '((guix build cmake-build-system)
                                        (guix build utils)))
+                            allowed-references
                             disallowed-references)
   "Cross-build NAME using CMAKE for TARGET, where TARGET is a GNU triplet and
 with INPUTS.  This assumes that SOURCE provides a 'CMakeLists.txt' file as its
@@ -250,6 +253,8 @@ build system."
                       #:target target
                       #:graft? #f
                       #:substitutable? substitutable?
+                      #:allowed-references allowed-references
+                      #:disallowed-references disallowed-references
                       #:guile-for-build guile)))
 
 (define cmake-build-system