summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/messaging.scm7
-rw-r--r--gnu/packages/patches/bitlbee-configure-doc-fix.patch15
3 files changed, 3 insertions, 20 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 20e38aeccb..502993b355 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -426,7 +426,6 @@ dist_patch_DATA =						\
   gnu/packages/patches/bigloo-gc-shebangs.patch			\
   gnu/packages/patches/binutils-ld-new-dtags.patch		\
   gnu/packages/patches/binutils-loongson-workaround.patch	\
-  gnu/packages/patches/bitlbee-configure-doc-fix.patch		\
   gnu/packages/patches/byobu-writable-status.patch		\
   gnu/packages/patches/calibre-drop-unrar.patch			\
   gnu/packages/patches/calibre-no-updates-dialog.patch		\
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 23c7a0bbdd..076c4dcdc6 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -101,14 +101,13 @@ keys, no previous conversation is compromised.")
 (define-public bitlbee
   (package
     (name "bitlbee")
-    (version "3.4")
+    (version "3.4.1")
     (source (origin
               (method url-fetch)
-              (uri (string-append "http://get.bitlbee.org/src/bitlbee-"
+              (uri (string-append "https://get.bitlbee.org/src/bitlbee-"
                                   version ".tar.gz"))
               (sha256
-               (base32 "0plx4dryf8i6hz7vghg84z5f6w6rkw1l8ckl4c4wh5zxpd3ddfnf"))
-              (patches (list (search-patch "bitlbee-configure-doc-fix.patch")))))
+               (base32 "1qf0ypa9ba5jvsnpg9slmaran16hcc5fnfzbb1sdch1hjhchn2jh"))))
     (build-system gnu-build-system)
     (native-inputs `(("pkg-config" ,pkg-config)
                      ("check" ,check)))
diff --git a/gnu/packages/patches/bitlbee-configure-doc-fix.patch b/gnu/packages/patches/bitlbee-configure-doc-fix.patch
deleted file mode 100644
index ade0b7f25c..0000000000
--- a/gnu/packages/patches/bitlbee-configure-doc-fix.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Fix the check for the prebuilt helpfile when xsltproc is not available.
-
---- bitlbee-3.4/configure.orig	2015-03-25 18:09:10.000000000 -0400
-+++ bitlbee-3.4/configure	2015-05-20 14:51:33.627975970 -0400
-@@ -650,8 +650,8 @@
- 
- if [ "$doc" = "1" ]; then
- 	if [ ! -e doc/user-guide/help.txt ] && \
--	     ! type xmlto > /dev/null 2> /dev/null || \
--	     ! type xsltproc > /dev/null 2> /dev/null
-+	     (! type xmlto > /dev/null 2> /dev/null || \
-+	      ! type xsltproc > /dev/null 2> /dev/null)
- 	then
- 		echo
- 		echo 'WARNING: Building from an unreleased source tree without prebuilt helpfile.'