summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/patches/qemu-multiple-smb-shares.patch20
-rw-r--r--gnu/packages/qemu.scm13
3 files changed, 0 insertions, 34 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 6d29f7c37c..bc12478202 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -319,7 +319,6 @@ dist_patch_DATA =						\
   gnu/packages/patches/procps-make-3.82.patch			\
   gnu/packages/patches/python-fix-tests.patch			\
   gnu/packages/patches/python-libffi-mips-n32-fix.patch		\
-  gnu/packages/patches/qemu-multiple-smb-shares.patch		\
   gnu/packages/patches/qt4-tests.patch				\
   gnu/packages/patches/ratpoison-shell.patch			\
   gnu/packages/patches/readline-link-ncurses.patch		\
diff --git a/gnu/packages/patches/qemu-multiple-smb-shares.patch b/gnu/packages/patches/qemu-multiple-smb-shares.patch
deleted file mode 100644
index 8e3c6ffe1c..0000000000
--- a/gnu/packages/patches/qemu-multiple-smb-shares.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-This file extends `-smb' to add a share for the Nix store, and changes
-the name of the default share.
-
---- a/net/slirp.c
-+++ b/net/slirp.c
-@@ -515,8 +515,12 @@ static int slirp_smb(SlirpState* s, const char *exported_dir,
-             "log file=%s/log.smbd\n"
-             "smb passwd file=%s/smbpasswd\n"
-             "security = share\n"
--            "[qemu]\n"
--            "path=%s\n"
-+            "[store]\n"
-+            "path=/gnu/store\n"
-+            "read only=yes\n"
-+            "guest ok=yes\n"
-+            "[xchg]\n"
-+            "path=%s/xchg\n"
-             "read only=no\n"
-             "guest ok=yes\n",
-             s->smb_dir,
diff --git a/gnu/packages/qemu.scm b/gnu/packages/qemu.scm
index 4567373aa9..b02998392e 100644
--- a/gnu/packages/qemu.scm
+++ b/gnu/packages/qemu.scm
@@ -132,19 +132,6 @@ server and embedded PowerPC, and S390 guests.")
     ;; Many files are GPLv2+, but some are GPLv2-only---e.g., `memory.c'.
     (license gpl2)))
 
-(define-public qemu/smb-shares
-  ;; A patched QEMU where `-net smb' yields two shares instead of one: one for
-  ;; the store, and another one for exchanges with the host.
-
-  ;; TODO: Use 9p/-virtfs instead of this SMB hack:
-  ;; <http://wiki.qemu.org/Documentation/9psetup>.
-  (package (inherit qemu-headless)
-    (name "qemu-with-multiple-smb-shares")
-    (source (origin (inherit (package-source qemu-headless))
-              (patches
-               (cons (search-patch "qemu-multiple-smb-shares.patch")
-                     (origin-patches (package-source qemu-headless))))))))
-
 (define-public qemu
   ;; QEMU with GUI support.
   (package (inherit qemu-headless)