summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/dns.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 08304b0c4c..d093b0d9b5 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -149,7 +149,8 @@ and BOOTP/TFTP for network booting of diskless machines.")
          ;;          (system "bin/tests/system/ifconfig.sh up")))
          (replace 'check
            (lambda _
-             (zero? (system* "make" "force-test")))))))
+             (invoke "make" "force-test")
+             #t)))))
     (synopsis "An implementation of the Domain Name System")
     (description "BIND is an implementation of the @dfn{Domain Name System}
 (DNS) protocols for the Internet.  It is a reference implementation of those