summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/commencement.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 69d1f87605..79f2e49008 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1719,6 +1719,17 @@ exec " gcc "/bin/" program
                   (arguments
                    `(#:tests? #f                  ;... and thus disable tests
 
+                     ;; XXX: These flags should be unconditional, but for now
+                     ;; we just add them on x86 to avoid a full rebuild.
+                     ;; TODO: On the next core-updates, use
+                     ;; 'substitute-keyword-arguments' to inherit them from
+                     ;; BISON.
+                     ,@(if (member (%current-system)
+                                   '("x86_64-linux" "i686-linux"))
+                           '(#:parallel-build? #f
+                             #:parallel-tests? #f)
+                           '())
+
                      ;; Zero timestamps in liby.a; this must be done
                      ;; explicitly here because the bootstrap Binutils don't
                      ;; do that (default is "cru".)