summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/mpi.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 01dc9e355b..ebf9238906 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -4,7 +4,7 @@
 ;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
 ;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2017 Dave Love <fx@gnu.org>
-;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018–2022 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Paul Garlick <pgarlick@tourbillion-technology.com>
 ;;; Copyright © 2019, 2021 Ricardo Wurmus <rekado@elephly.net>
@@ -217,17 +217,21 @@ bind processes, and much more.")
                (if-supported psm)
                (if-supported psm2)
                (if-supported ucx)
+               (if-supported valgrind)
                (list rdma-core
-                     valgrind
                      slurm))))         ;for PMI support (launching via "srun")
     (native-inputs
      (list pkg-config perl))
     (outputs '("out" "debug"))
     (arguments
      `(#:configure-flags `("--enable-mpi-ext=affinity" ;cr doesn't work
-                           "--enable-memchecker"
                            "--with-sge"
-                           "--with-valgrind"
+
+                           ,@(if ,(package? (this-package-input "valgrind"))
+                               `("--enable-memchecker"
+                                 "--with-valgrind")
+                               `("--without-valgrind"))
+
                            "--with-hwloc=external"
                            "--with-libevent"