summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/cobol.scm32
1 files changed, 17 insertions, 15 deletions
diff --git a/gnu/packages/cobol.scm b/gnu/packages/cobol.scm
index 296a9880a6..a67eef3cd4 100644
--- a/gnu/packages/cobol.scm
+++ b/gnu/packages/cobol.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017, 2018, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2018, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -22,6 +22,7 @@
   #:use-module (guix licenses)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix gexp)
   #:use-module (gnu packages dbm)
   #:use-module (gnu packages multiprecision)
   #:use-module (gnu packages ncurses)
@@ -43,21 +44,22 @@
          (base32
           "0x15ybfm63g7c9340fc6712h9v59spnbyaz4rf85pmnp3zbhaw2r"))))
     (arguments
-     '(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
-                                              (assoc-ref %outputs "out")
-                                              "/lib")
-                               (string-append "JSON_C_CFLAGS=-I"
-                                              (assoc-ref %build-inputs "json-c")
-                                              "/include/json-c"))
+     (list
+       #:configure-flags
+       #~(list (string-append "LDFLAGS=-Wl,-rpath="
+                              #$output "/lib")
+               (string-append "JSON_C_CFLAGS=-I"
+                              (search-input-directory %build-inputs
+                              "/include/json-c")))
        #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'place-cobol85-test-suite
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let ((newcob (assoc-ref inputs "newcob")))
-               (copy-file newcob "tests/cobol85/newcob.val.Z"))))
-         (add-before 'check 'set-TERM
-           ;; Some tests expect a known terminal
-           (lambda _ (setenv "TERM" "xterm-256color"))))
+       #~(modify-phases %standard-phases
+           (add-after 'unpack 'place-cobol85-test-suite
+             (lambda* (#:key inputs #:allow-other-keys)
+               (let ((newcob (assoc-ref inputs "newcob")))
+                 (copy-file newcob "tests/cobol85/newcob.val.Z"))))
+           (add-before 'check 'set-TERM
+             ;; Some tests expect a known terminal
+             (lambda _ (setenv "TERM" "xterm-256color"))))
        #:test-target "checkall"))
     (native-inputs
      `(("perl" ,perl)