summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/w3m.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/w3m.scm b/gnu/packages/w3m.scm
index 39d5e3c37f..498bf0f111 100644
--- a/gnu/packages/w3m.scm
+++ b/gnu/packages/w3m.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2016, 2017, 2018 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016, 2017, 2018, 2023 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
@@ -42,6 +42,9 @@
 (define-public w3m
   (package
     (name "w3m")
+    ;; When updating, be careful not to change the derivation of w3m-for-tests,
+    ;; unless you mean to. Changing w3m-for-tests will cause thousands of
+    ;; rebuilds via the reverse dependency graph of xdg-utils.
     (version "0.5.3+git20230121")
     (source (origin
               (method git-fetch)
@@ -86,3 +89,21 @@ window.  Moreover, w3m can be used as a text formatting tool which
 typesets HTML into plain text.")
     (license (x11-style "file://doc/README"
                         "See 'doc/README' in the distribution."))))
+
+;; Used in the test suite of xdg-utils
+(define-public w3m-for-tests
+  (hidden-package
+   (package
+     (inherit w3m)
+     (name "w3m")
+     (version "0.5.3+git20230121")
+     (source (origin
+               (method git-fetch)
+               ;; Debian's fork of w3m is the only one that is still maintained.
+               (uri (git-reference
+                     (url "https://salsa.debian.org/debian/w3m.git")
+                     (commit (string-append "v" version))))
+               (file-name (git-file-name name version))
+               (sha256
+                (base32
+                 "0nvhxsqxgxjrr62mvxzhhfzvbvg56g19vlqcgb8mh2x1daazk5ms")))))))