summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/node.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 41c01cf7e4..c8d81fbd22 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -128,7 +128,7 @@
                        (cons sigxfsz common)
                        common))
                (("'/bin/sh'")
-                (string-append "'" (assoc-ref inputs "bash") "/bin/sh'")))
+                (string-append "'"  (search-input-file inputs "/bin/sh") "'")))
 
              ;; Fix hardcoded /usr/bin/env references.
              (substitute* '("test/parallel/test-child-process-default-options.js"
@@ -245,7 +245,8 @@
                                   (search-input-file inpts "/bin/python3")
                                   (raise-exception e)))
                           (lambda ()
-                            (search-input-file inpts "/bin/python"))))
+                            (search-input-file inpts "/bin/python"))
+                          #:unwind? #t))
                       "configure"
                       flags))))
          (add-after 'patch-shebangs 'patch-nested-shebangs