summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/kde-pim.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 6ca2af37d0..e95eac4e2f 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -954,8 +954,11 @@ package.")
                  (lambda* (#:key tests? #:allow-other-keys)
                    (when tests?
                      (setenv "HOME" (getcwd))
-                     ;; XXX: Those tests fails randomly.
-                     (invoke "ctest" "-E" "kgpg-import|kgpg-export")))))))
+                     (invoke "ctest")))))
+           ;; XXX: Tests could fail randomly with:
+           ;;   gpg: can't connect to the agent: IPC connect call failed
+           ;;   gpg process did not finish. Cannot generate a new key pair.
+           #:tests? #f))
     (native-inputs
      (list extra-cmake-modules
            gnupg ;; TODO: Remove after gpgme uses fixed path