summary refs log tree commit diff
path: root/gnu/packages/authentication.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/authentication.scm')
-rw-r--r--gnu/packages/authentication.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/authentication.scm b/gnu/packages/authentication.scm
index de1769d65f..7c7fb8e861 100644
--- a/gnu/packages/authentication.scm
+++ b/gnu/packages/authentication.scm
@@ -62,15 +62,14 @@
 (define-public oath-toolkit
   (package
     (name "oath-toolkit")
-    (version "2.6.7")
+    (version "2.6.9")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://download.savannah.nongnu.org/releases/"
                            name "/" name "-" version ".tar.gz"))
-       (patches (search-patches "oath-toolkit-xmlsec-compat.patch"))
        (sha256
-        (base32 "1aa620k05lsw3l3slkp2mzma40q3p9wginspn9zk8digiz7dzv9n"))))
+        (base32 "11g9r1avl3d2nnkglk0g7d6z6gs5padk75xqzvbxp9pir0qwhfik"))))
     (build-system gnu-build-system)
     (arguments
      ;; TODO ‘--enable-pskc’ causes xmlsec-related test suite failures.
@@ -93,16 +92,16 @@
     (inputs
      (list linux-pam openssl xmlsec-openssl))
     (home-page "https://www.nongnu.org/oath-toolkit/")
-    (synopsis "One-time password (OTP) components")
+    (synopsis "@acronym{OTP, one-time password} components")
     (description
-     "The @dfn{OATH} (Open AuTHentication) Toolkit provides various components
-for building one-time password (@dfn{OTP}) authentication systems:
+     "The @acronym{OATH, Open AuTHentication} Toolkit provides various
+components for building @acronym{OTP, One-Time Password} authentication systems:
 
 @itemize
 @item @command{oathtool}, a command-line tool for generating & validating OTPs.
 @item @code{liboath}, a C library for OATH handling.
 @item @command{pskctool}, a command-line tool for manipulating secret key
-files in the Portable Symmetric Key Container (@dfn{PSKC}) format
+files in the @acronym{PSKC, Portable Symmetric Key Container} format
 described in RFC6030.
 @item @code{libpskc}, a shared and static C library for PSKC handling.
 @item @code{pam_oath}, a PAM module for pluggable login authentication.
@@ -111,8 +110,7 @@ described in RFC6030.
 Supported technologies include the event-based @acronym{HOTP, Hash-based Message
 Authentication Code One-Time Password} algorithm (RFC4226), the time-based
 @acronym{TOTP, Time-based One-Time Password} algorithm (RFC6238), and
-@acronym{PSKC, Portable Symmetric Key Container} (RFC6030) to manage secret key
-data.")
+PSKC (RFC6030) to manage secret key data.")
     (license (list license:lgpl2.1+     ; the libraries (liboath/ & libpskc/)
                    license:gpl3+))))    ; the tools (everything else)