summary refs log tree commit diff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 619c5cb57a..4bdb9ca059 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -61,8 +61,8 @@
       (sha256
        (base32
         "0jh79syhr8n3l81jxlwsmwm1pklb4d923m2lgqbswyavh1fqmvwb"))
-      (patches (list (search-patch "duplicity-piped-password.patch")
-                     (search-patch "duplicity-test_selection-tmp.patch")))))
+      (patches (search-patches "duplicity-piped-password.patch"
+                               "duplicity-test_selection-tmp.patch"))))
     (build-system python-build-system)
     (native-inputs
      `(("python2-setuptools" ,python2-setuptools)
@@ -146,10 +146,10 @@ backups (called chunks) to allow easy burning to CD/DVD.")
         (base32
          "0pixqnrcf35dnqgv0lp7qlcw7k13620qkhgxr288v7p4iz6ym1zb"))
        (patches
-        (list (search-patch "libarchive-mtree-filename-length-fix.patch")
-              (search-patch "libarchive-fix-lzo-test-case.patch")
-              (search-patch "libarchive-CVE-2013-0211.patch")
-              (search-patch "libarchive-bsdtar-test.patch")))))
+        (search-patches "libarchive-mtree-filename-length-fix.patch"
+                        "libarchive-fix-lzo-test-case.patch"
+                        "libarchive-CVE-2013-0211.patch"
+                        "libarchive-bsdtar-test.patch"))))
     (build-system gnu-build-system)
     ;; TODO: Add -L/path/to/nettle in libarchive.pc.
     (inputs
@@ -377,8 +377,7 @@ changes are stored.")
               (sha256
                (base32
                 "0fpdyxww41ba52d98blvnf543xvirq1v9xz1i3x1gm9lzlzpmc2g"))
-              (patches
-               (list (search-patch "diffutils-gets-undeclared.patch")))))
+              (patches (search-patches "diffutils-gets-undeclared.patch"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("guile" ,guile-2.0)