summary refs log tree commit diff
path: root/gnu/packages/base.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/base.scm')
-rw-r--r--gnu/packages/base.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 2ed9de0d5d..b1bc5ca2d1 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -270,9 +270,13 @@ The tools supplied with this package are:
              (base32
               "064f512185iysqqcvhnhaf3bfmzrvcgs7n405qsyp99zmfyl9amd"))))
    (build-system gnu-build-system)
-   (inputs `(("acl"  ,acl)
+   (inputs `(("acl"  ,acl)                        ; TODO: add SELinux
              ("gmp"  ,gmp)
-             ("perl" ,perl)))                     ; TODO: add SELinux
+
+             ;; Perl is needed to run tests; remove it from cross builds.
+             ,@(if (%current-target-system)
+                   '()
+                   `(("perl" ,perl)))))
    (arguments
     `(#:parallel-build? #f            ; help2man may be called too early
       #:phases (alist-cons-before
@@ -287,7 +291,9 @@ The tools supplied with this package are:
                     (substitute* (find-files "tests" "\\.sh$")
                       (("#!/bin/sh")
                        (format #f "#!~a/bin/bash" bash)))))
-                %standard-phases)))
+                ,(if (%current-target-system)
+                     '%standard-cross-phases
+                     '%standard-phases))))
    (synopsis "Core GNU utilities (file, text, shell)")
    (description
     "The GNU Core Utilities are the basic file, shell and text manipulation