summary refs log tree commit diff
path: root/gnu/packages/bdb.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bdb.scm')
-rw-r--r--gnu/packages/bdb.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/bdb.scm b/gnu/packages/bdb.scm
index 9a626b17d7..75a2b72b44 100644
--- a/gnu/packages/bdb.scm
+++ b/gnu/packages/bdb.scm
@@ -45,7 +45,11 @@
             (system* "./dist/configure"
                      (string-append "--prefix=" out)
                      (string-append "CONFIG_SHELL=" (which "bash"))
-                     (string-append "SHELL=" (which "bash"))))))
+                     (string-append "SHELL=" (which "bash"))
+
+                     ;; The compatibility mode is needed by some packages,
+                     ;; notably iproute2.
+                     "--enable-compat185"))))
        %standard-phases)))
    (synopsis "db, the Berkeley database")
    (description