summary refs log tree commit diff
path: root/gnu/packages/cluster.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cluster.scm')
-rw-r--r--gnu/packages/cluster.scm21
1 files changed, 6 insertions, 15 deletions
diff --git a/gnu/packages/cluster.scm b/gnu/packages/cluster.scm
index 3043760830..d27544e992 100644
--- a/gnu/packages/cluster.scm
+++ b/gnu/packages/cluster.scm
@@ -165,13 +165,9 @@ connection.  This package contains the userland utilities.")
                              (string-append infodir "/keepalived-figures"))
                #t))))))
     (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("python-sphinx" ,python-sphinx)
-       ("texinfo" ,texinfo)))
+     (list pkg-config python-sphinx texinfo))
     (inputs
-     `(("openssl" ,openssl)
-       ("libnfnetlink" ,libnfnetlink)
-       ("libnl" ,libnl)))
+     (list openssl libnfnetlink libnl))
     (home-page "https://www.keepalived.org/")
     (synopsis "Load balancing and high-availability frameworks")
     (description
@@ -204,8 +200,7 @@ independently or together to provide resilient infrastructures.")
                          ((".*test_uv_append.c.*") ""))
                        #t)))))
     (inputs
-     `(("libuv" ,libuv)
-       ("lz4" ,lz4)))
+     (list libuv lz4))
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)
@@ -245,15 +240,11 @@ snapshots).")
                ;; race condition when tearing down the test server.
                ((".*test_client.c.*") "")))))))
     (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("libtool" ,libtool)
-       ("pkg-config" ,pkg-config)))
+     (list autoconf automake libtool pkg-config))
     (inputs
-     `(("libraft" ,libraft)
-       ("libuv" ,libuv)))
+     (list libraft libuv))
     (propagated-inputs
-     `(("sqlite" ,sqlite)))  ; dqlite.h includes sqlite3.h
+     (list sqlite))  ; dqlite.h includes sqlite3.h
     (build-system gnu-build-system)
     (synopsis "Distributed SQLite")
     (description "dqlite is a C library that implements an embeddable and replicated