summary refs log tree commit diff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm18
1 files changed, 16 insertions, 2 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 80fdb5aed7..03fecd6d9b 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3365,6 +3365,16 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
      `(("glibc" ,glibc-final)
        ("gzip" ,(with-boot4 gzip))))))
 
+(define-public glibc-utf8-locales-final/hurd
+  ;; Locales for the libc version used on GNU/Hurd.
+  (package
+    (inherit glibc-utf8-locales/hurd)
+    (properties `((hidden? . #t)
+                  ,@(package-properties glibc-utf8-locales/hurd)))
+    (native-inputs
+     `(("glibc" ,glibc-final)
+       ("gzip" ,(with-boot4 gzip))))))
+
 (define-public ld-wrapper
   ;; The final 'ld' wrapper, which uses the final Guile and Binutils.
   (make-ld-wrapper "ld-wrapper"
@@ -3383,7 +3393,9 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
   ;; Now with UTF-8 locales.  Remember that the bootstrap binaries were built
   ;; with an older libc, which cannot load the new locale format.  See
   ;; <https://lists.gnu.org/archive/html/guix-devel/2015-08/msg00737.html>.
-  `(("locales" ,glibc-utf8-locales-final)
+  `(("locales" ,(if (target-hurd?)
+                    glibc-utf8-locales-final/hurd
+                    glibc-utf8-locales-final))
     ,@(%boot4-inputs)))
 
 (define with-boot5
@@ -3484,7 +3496,9 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
           ("gcc" ,gcc-final)
           ("libc" ,glibc-final)
           ("libc:static" ,glibc-final "static")
-          ("locales" ,glibc-utf8-locales-final))))))
+          ("locales" ,(if (target-hurd? (%current-system))
+                          glibc-utf8-locales-final/hurd
+                          glibc-utf8-locales-final)))))))
 
 (define-public canonical-package
   (let ((name->package (mlambda (system)