summary refs log tree commit diff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index abb50d81b2..685dc02fca 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -928,17 +928,18 @@ conversions to and from strings, iteration and related functionality.")
      `(#:configure-flags
        '("-DCLI11_SINGLE_FILE=OFF"
          "-DCLI11_BUILD_EXAMPLES=OFF")
-       #:imported-modules ,(append %cmake-build-system-modules
-                                   (source-module-closure '((guix utils))))
+       #:imported-modules ,%cmake-build-system-modules
+       #:modules ((guix build cmake-build-system)
+                  (guix build utils))
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'no-vendor-gtest
            (lambda _
-             (use-modules (guix utils))
              (substitute* "tests/CMakeLists.txt"
-               ;; We provide our own googletest, so this is not really a problem.
-               (("message\\(FATAL_ERROR \"You have requested tests be built, but googletest is not downloaded." msg)
-                 (string-replace-substring msg "FATAL_ERROR" "TRACE")))
+               ;; We provide our own googletest, so this is not really a
+               ;; problem.
+               (("message\\(FATAL_ERROR \"You have requested")
+                "message(TRACE \"You have requested"))
              (substitute* "cmake/AddGoogletest.cmake"
                (("^add_subdirectory\\(.*googletest.*$") "find_package(GTest REQUIRED)")
                (("^set_target_properties\\(gtest gtest_main gmock gmock_main") "")