summary refs log tree commit diff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 0ea80ea237..ec1f4cd325 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -691,14 +691,15 @@ intuitive syntax and trivial integration.")
     (native-inputs
      (list doctest googletest nlohmann-json))
     (arguments
-     '(#:configure-flags
-       '("-DBUILD_TESTS=ON")
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* _
-             (with-directory-excursion "test"
-               (invoke "./test_xtl")))))))
+     (list
+      #:configure-flags
+      #~(list "-DBUILD_TESTS=ON")
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda _
+              (with-directory-excursion "test"
+                (invoke "./test_xtl")))))))
     (home-page "https://github.com/QuantStack/xtl")
     (build-system cmake-build-system)
     (synopsis "C++ template library providing some basic tools")