summary refs log tree commit diff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm66
1 files changed, 0 insertions, 66 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7d032f775a..5f4ef77284 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -59708,48 +59708,6 @@ quickly convert floating point numbers to decimal strings.")
      "This package provides a procedural macros for the salsa crate.")
     (license (list license:asl2.0 license:expat))))
 
-(define-public rust-salsa20-0.10
-  (package
-    (name "rust-salsa20")
-    (version "0.10.2")
-    (source (origin
-              (method url-fetch)
-              (uri (crate-uri "salsa20" version))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "04w211x17xzny53f83p8f7cj7k2hi8zck282q5aajwqzydd2z8lp"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs
-       (("rust-cipher" ,rust-cipher-0.4))
-       #:cargo-development-inputs
-       (("rust-cipher" ,rust-cipher-0.4)
-        ("rust-hex-literal" ,rust-hex-literal-0.3))))
-    (home-page "https://github.com/RustCrypto/stream-ciphers")
-    (synopsis "Salsa20 Stream Cipher")
-    (description "Salsa20 is a collection of stream cipher algorithms written
-in pure Rust.")
-    (license (list license:expat license:asl2.0))))
-
-(define-public rust-salsa20-0.9
-  (package
-    (inherit rust-salsa20-0.10)
-    (name "rust-salsa20")
-    (version "0.9.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "salsa20" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "11i646kpgimimqiq8hyi0b7ngp588f7nl9xsc317d9kdcxgvn3qc"))))
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-cipher" ,rust-cipher-0.3)
-        ("rust-zeroize" ,rust-zeroize-1))))))
-
 (define-public rust-salsa-0.17
   (package
     (name "rust-salsa")
@@ -59794,30 +59752,6 @@ in pure Rust.")
 computation (experimental)")
     (license (list license:asl2.0 license:expat))))
 
-(define-public rust-salsa20-0.7
-  (package
-    (name "rust-salsa20")
-    (version "0.7.1")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (crate-uri "salsa20" version))
-        (file-name (string-append name "-" version ".tar.gz"))
-        (sha256
-          (base32 "09c16m566g45f41xx3673zyzwca3mykz630fmv2mbjbvmwcc4fw0"))))
-    (build-system cargo-build-system)
-    (arguments
-      `(#:cargo-inputs
-        (("rust-cipher" ,rust-cipher-0.2)
-         ("rust-zeroize" ,rust-zeroize-1))
-        #:cargo-development-inputs
-        (("rust-cipher" ,rust-cipher-0.2))))
-    (home-page "https://github.com/RustCrypto/stream-ciphers")
-    (synopsis "Salsa20 stream cipher")
-    (description "This is a Rust library implementing the Salsa20 stream
-cipher.")
-    (license (list license:expat license:asl2.0))))
-
 (define-public rust-safe-arch-0.6
   (package
     (name "rust-safe-arch")