summary refs log tree commit diff
path: root/gnu/packages/crates-vcs.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-vcs.scm')
-rw-r--r--gnu/packages/crates-vcs.scm44
1 files changed, 35 insertions, 9 deletions
diff --git a/gnu/packages/crates-vcs.scm b/gnu/packages/crates-vcs.scm
index 7468688c28..781e906ad3 100644
--- a/gnu/packages/crates-vcs.scm
+++ b/gnu/packages/crates-vcs.scm
@@ -3869,8 +3869,42 @@ types and utilities.  Part of Gitoxide a pure Rust implementation of Git.")
         ("rust-tempfile" ,rust-tempfile-3)
         ("rust-walkdir" ,rust-walkdir-2))))))
 
+(define-public rust-gix-worktree-state-0.4
+  (package
+    (name "rust-gix-worktree-state")
+    (version "0.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "gix-worktree-state" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1m5y0qsf8r7sl6ffvi5ymd6497a5mb4k3pq31b072g5gvk6gr8il"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-bstr" ,rust-bstr-1)
+                       ("rust-gix-features" ,rust-gix-features-0.36)
+                       ("rust-gix-filter" ,rust-gix-filter-0.6)
+                       ("rust-gix-fs" ,rust-gix-fs-0.8)
+                       ("rust-gix-glob" ,rust-gix-glob-0.14)
+                       ("rust-gix-hash" ,rust-gix-hash-0.13)
+                       ("rust-gix-index" ,rust-gix-index-0.26)
+                       ("rust-gix-object" ,rust-gix-object-0.38)
+                       ("rust-gix-path" ,rust-gix-path-0.10)
+                       ("rust-gix-worktree" ,rust-gix-worktree-0.27)
+                       ("rust-io-close" ,rust-io-close-0.3)
+                       ("rust-thiserror" ,rust-thiserror-1))))
+    (home-page "https://github.com/Byron/gitoxide")
+    (synopsis
+     "Gitoxide project functions that set Git's worktree to a particular state")
+    (description
+     "This package provides functions for setting the Git worktree to a particular
+state.  Used by Gitoxide a pure Rust implementation of Git.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-gix-worktree-state-0.3
   (package
+    (inherit rust-gix-worktree-state-0.4)
     (name "rust-gix-worktree-state")
     (version "0.3.0")
     (source
@@ -3880,7 +3914,6 @@ types and utilities.  Part of Gitoxide a pure Rust implementation of Git.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "1bcpspxpvl8yybz8b0p64pjxb69b7kmkhsyv9jgarigjc1lv1bn3"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs (("rust-bstr" ,rust-bstr-1)
                        ("rust-gix-features" ,rust-gix-features-0.35)
@@ -3893,14 +3926,7 @@ types and utilities.  Part of Gitoxide a pure Rust implementation of Git.")
                        ("rust-gix-path" ,rust-gix-path-0.10)
                        ("rust-gix-worktree" ,rust-gix-worktree-0.26)
                        ("rust-io-close" ,rust-io-close-0.3)
-                       ("rust-thiserror" ,rust-thiserror-1))))
-    (home-page "https://github.com/Byron/gitoxide")
-    (synopsis
-     "Gitoxide project functions that set Git's worktree to a particular state")
-    (description
-     "This package provides functions for setting the Git worktree to a particular
-state.  Used by Gitoxide a pure Rust implementation of Git.")
-    (license (list license:expat license:asl2.0))))
+                       ("rust-thiserror" ,rust-thiserror-1))))))
 
 (define-public rust-gix-worktree-stream-0.5
   (package