summary refs log tree commit diff
path: root/gnu/packages/dav.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/dav.scm')
-rw-r--r--gnu/packages/dav.scm40
1 files changed, 22 insertions, 18 deletions
diff --git a/gnu/packages/dav.scm b/gnu/packages/dav.scm
index 7eb62401e9..e0306b8a97 100644
--- a/gnu/packages/dav.scm
+++ b/gnu/packages/dav.scm
@@ -24,6 +24,7 @@
 (define-module (gnu packages dav)
   #:use-module (guix build-system python)
   #:use-module (guix download)
+  #:use-module (guix gexp)
   #:use-module (guix licenses)
   #:use-module (guix packages)
   #:use-module (guix git-download)
@@ -84,13 +85,13 @@ clients.")
 (define-public xandikos
   (package
     (name "xandikos")
-    (version "0.2.3")
+    (version "0.2.8")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "xandikos" version))
        (sha256
-        (base32 "13ikmcja9p42azb5ccqj2bw98zybna6zlflj10hqy0kvbib70l94"))))
+        (base32 "00ghmzcc37b17pp0r6d9v5vpxmz500kzxqj1k9ppcjhbbpvp9w8n"))))
     (build-system python-build-system)
     (propagated-inputs
      (list python-aiohttp
@@ -122,29 +123,32 @@ efficient syncing
 (define-public vdirsyncer
   (package
     (name "vdirsyncer")
-    (version "0.19.1")
+    (version "0.19.2")
     (source (origin
              (method url-fetch)
              (uri (pypi-uri name version))
              (sha256
               (base32
-               "1bh3kz0d8g07xnlkb5l2fj6fdakqps1wviab6zv139x5b9rcfxma"))))
+               "1fl21m10ghrpmkqa12g0qri99cxk9879pkb60jd4b4w2mgp8q1gx"))))
     (build-system python-build-system)
     (arguments
-     `(#:tests? #f ; The test suite is very flakey.
-       #:phases (modify-phases %standard-phases
-        (replace 'check
-          (lambda* (#:key inputs outputs tests? #:allow-other-keys)
-            (add-installed-pythonpath inputs outputs)
-            (setenv "DETERMINISTIC_TESTS" "true")
-            (setenv "DAV_SERVER" "radicale")
-            (setenv "REMOTESTORAGE_SERVER" "skip")
-            (if tests?
-                (invoke "make" "test"))))
-        (add-after 'unpack 'patch-version-call
-          (lambda _
-            (substitute* "docs/conf.py"
-              (("^release.*") (string-append "release = '" ,version "'\n"))))))))
+     (list
+      #:tests? #f                       ; the test suite is very flakey
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+              (add-installed-pythonpath inputs outputs)
+              (setenv "DETERMINISTIC_TESTS" "true")
+              (setenv "DAV_SERVER" "radicale")
+              (setenv "REMOTESTORAGE_SERVER" "skip")
+              (if tests?
+                  (invoke "make" "test"))))
+          (add-after 'unpack 'patch-version-call
+            (lambda _
+              (substitute* "docs/conf.py"
+                (("^release.*")
+                 (string-append "release = '" #$version "'\n"))))))))
     (native-inputs
      (list python-setuptools-scm
            python-sphinx