summary refs log tree commit diff
path: root/gnu/packages/education.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/education.scm')
-rw-r--r--gnu/packages/education.scm203
1 files changed, 0 insertions, 203 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 213c8f717b..3b9c01c786 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -445,109 +445,6 @@ specialized device.")
     (home-page "https://bipede.fr/contrib/")
     (license license:gpl3)))
 
-(define-public childsplay
-  (package
-    (name "childsplay")
-    (version "3.4")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "mirror://sourceforge/schoolsplay/"
-                    "childsplay-" version ".tgz"))
-              (sha256
-               (base32
-                "0z7yp2swjnbz51vn2zyfnjn40jq38l5mbh15yafmx1z3vn2z1m77"))))
-    (build-system python-build-system)
-    (arguments
-     `(#:python ,python-2
-       #:tests? #f
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'unbundle-dejavu-font
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let* ((dejavu-dir
-                     (string-append (assoc-ref inputs "font-dejavu")
-                                    "/share/fonts/truetype"))
-                    (dejavu-font
-                     (string-append dejavu-dir
-                                    "/DejaVuSansCondensed-Bold.ttf")))
-               (substitute* "SPConstants.py"
-                 (("^(TTF(BOLD)? = ).*" _ prefix)
-                  (string-append prefix "'" dejavu-font "'\n")))
-               (for-each (lambda (f) (delete-file f))
-                         (find-files "lib/SPData" "DejaVu"))
-               #t)))
-         (delete 'build)
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (pixmaps (string-append out "/share/pixmaps"))
-                    (share (string-append out "/share/childsplay"))
-                    (doc (string-append out "/share/doc/" ,name "-",version)))
-               ;; Install icon.
-               (install-file "lib/SPData/themes/childsplay/logo_cp.svg" pixmaps)
-               ;; Install data.
-               (mkdir-p share)
-               (for-each (lambda (f)
-                           (copy-recursively f (string-append share "/" f)))
-                         '("alphabet-sounds" "lib" "locale" "SPWidgets"))
-               (for-each (lambda (f) (install-file f share))
-                         (find-files "." "\\.(py|dev|db)$"))
-               ;; Install documentation.
-               (mkdir-p doc)
-               (copy-recursively "docs" doc)
-               #t)))
-         (add-after 'install 'create-executable
-           (lambda* (#:key outputs inputs #:allow-other-keys)
-             (let* ((python (search-input-file inputs "/bin/python"))
-                    (out (assoc-ref outputs "out"))
-                    (bin (string-append out "/bin"))
-                    (executable (string-append bin "/childsplay")))
-               (mkdir-p bin)
-               (call-with-output-file executable
-                 (lambda (file)
-                   (format file
-                           "~a ~a"
-                           python
-                           (string-append out "/share/childsplay/childsplay.py"))))
-               (chmod executable #o555)
-               #t)))
-         (add-after 'install 'create-desktop-file
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (applications (string-append out "/share/applications")))
-               (mkdir-p applications)
-               (call-with-output-file
-                   (string-append applications "/childsplay.desktop")
-                 (lambda (file)
-                   (format file
-                           "[Desktop Entry]~@
-                            Name=Childsplay~@
-                            Comment=Suite of educational games for young children~@
-                            Comment[ca]=Conjunt de jocs educatius per a xiquets~@
-                            Comment[es]=Conjunto de juegos educativos para niños~@
-                            Comment[de]=Sammlung mit lehrreichen Spielen für kleine Kinder~@
-                            Exec=~a/bin/childsplay~@
-                            Terminal=false~@
-                            Icon=logo_cp.svg~@
-                            Type=Application~@
-                            Categories=Application;Game;Education;KidsGame;~@
-                            Keywords=suite;children;games;young;educational;~%"
-                           out)))
-               #t))))))
-    (inputs
-     `(("font-dejavu" ,font-dejavu)
-       ("pygame" ,python2-pygame)
-       ("sqlalchemy" ,python2-sqlalchemy)))
-    (synopsis "Suite of educational games for young children")
-    (description "Childsplay is a collection of educational activities
-for young children.  Childsplay can be used at home, kindergartens and
-pre-schools.  Childsplay is a fun and safe way to let young children
-use the computer and at the same time teach them a little math,
-letters of the alphabet, spelling, eye-hand coordination, etc.")
-    (home-page "http://www.schoolsplay.org")
-    (license license:gpl3+)))
-
 (define-public openboard
   ;; The last release builds from qtwebkit, which is planned for removal in
   ;; Guix, so use the latest commit of the 1.7-dev branch, which builds with
@@ -679,106 +576,6 @@ used both with interactive whiteboards or in a dual-screen setup with
 a pen-tablet display and a beamer.")
       (license license:gpl3))))
 
-(define-public omnitux
-  (package
-    (name "omnitux")
-    (version "1.2.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "mirror://sourceforge/omnitux/omnitux/"
-                           "v" version "/omnitux-" version ".tar.bz2"))
-       (sha256
-        (base32 "1wmmmbzmxd0blhn00d4g91xwavnab143a31ca3i8hrqgzh6qz9w6"))
-       (modules '((guix build utils)))
-       (snippet
-        '(begin
-           ;; Remove pre-compiled .pyc files from source.
-           (for-each delete-file (find-files "bin" "\\.pyc$"))
-           #t))))
-    (build-system python-build-system)
-    (inputs
-     (list python2-pygame python2-pygtk))
-    (arguments
-     `(#:tests? #f                      ;no test
-       #:python ,python-2
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'build)                ;no setup.py
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (share (string-append out "/share"))
-                    (data (string-append share "/omnitux")))
-               ;; Install documentation.
-               (let ((doc (string-append share "/doc/" ,name "-" ,version)))
-                 (for-each (lambda (f) (install-file f doc))
-                           '("LICENSE.txt" "README.txt")))
-               ;; Install data.
-               (install-file "omnitux.sh" data)
-               (for-each (lambda (d)
-                           (copy-recursively d (string-append data "/" d)))
-                         '("bin" "data"))
-               ;; Install the launcher.
-               (let* ((bin (string-append out "/bin"))
-                      (script (string-append bin "/omnitux"))
-                      (bash (search-input-file %build-inputs "/bin/bash"))
-                      (python (search-input-file %build-inputs
-                                                 "/bin/python2")))
-                 (mkdir-p bin)
-                 (with-output-to-file script
-                   (lambda ()
-                     (format #t "#!~a~%" bash)
-                     (format #t
-                             "cd ~a; ~a menu.py~%"
-                             (string-append data "/bin")
-                             python)))
-                 (chmod script #o755))
-               ;; Install icon and desktop file.
-               (let ((pixmaps (string-append share "/pixmaps")))
-                 (install-file "data/default/icons/Omnitux_logo.svg" pixmaps))
-               (let ((apps (string-append out "/share/applications")))
-                 (mkdir-p apps)
-                 (with-output-to-file (string-append apps "/omnitux.desktop")
-                   (lambda _
-                     (format #t
-                             "[Desktop Entry]~@
-                              Name=Omnitux~@
-                              GenericName=Omnitux
-                              Comment=An educational game based on multimedia elements.~@
-                              Comment[fr]=Un jeu ludo-éducatif basé sur des éléments multimédias.~@
-                              Exec=~a/bin/omnitux~@
-                              Type=Application~@
-                              Categories=Game;Education;~@
-                              Terminal=false~@
-                              Icon=Omnitux_logo.svg~@"
-                             out))))
-               #t))))))
-    (home-page "http://omnitux.sourceforge.net/")
-    (synopsis "Educational activities based on multimedia elements")
-    (description "The project aims to provide various educational
-activities around multimedia elements (images, sounds, texts).  Types
-of activities include:
-@itemize
-@item associations,
-@item items to place on a map or a schema,
-@item counting activities,
-@item puzzles,
-@item card faces to remember,
-@item find differences between two pictures,
-@item ...
-@end itemize
-
-Activities are available in English, French, German, Polish,
-Portuguese, Spanish and Italian.")
-    ;; Project's license is GPL3+, but multimedia elements are
-    ;; released under various licenses.
-    (license (list license:gpl3+
-                   license:gpl2+
-                   license:cc-by-sa2.0
-                   license:cc-by-sa3.0
-                   license:public-domain))))
-
 (define-public fet
   (package
     (name "fet")