summary refs log tree commit diff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9c23c69f79..30f924a3fb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27793,10 +27793,12 @@ files are easily readable and they work nicely with version control systems.")
                  (install-file "octicons.ttf" fonts)
                  (install-file "weathericons.ttf" fonts)))))
          (replace 'check
-           (lambda* (#:key outputs #:allow-other-keys)
-             (apply invoke "ert-runner" "-l"
-                    (append (find-files "data" "\\.el")
-                            '("all-the-icons-faces.el"))))))))
+           (lambda* (#:key tests? outputs #:allow-other-keys)
+             (if tests?
+                 (apply invoke "ert-runner" "-l"
+                        (append (find-files "data" "\\.el")
+                                '("all-the-icons-faces.el")))
+                 (format #t "test suite not run~%")))))))
     (native-inputs
      (list emacs-f emacs-ert-runner))
     (propagated-inputs