summary refs log tree commit diff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 0f290de7eb..cc9020c6fd 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1787,6 +1787,7 @@ analyzer (FFT) and frequency sweep plot.")
     (version "5.0.1")
     (source (origin
               (method git-fetch)
+              (patches (search-patches "capstone-fix-python-constants.patch"))
               (uri (git-reference
                     (url "https://github.com/capstone-engine/capstone")
                     (commit version)))
@@ -1798,7 +1799,7 @@ analyzer (FFT) and frequency sweep plot.")
     (arguments
      `(#:tests? #f
        #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
-                          "CC=gcc")
+                          (string-append "CC=" ,(cc-for-target)))
        #:phases
        (modify-phases %standard-phases
          (delete 'configure)            ; no configure script