summary refs log tree commit diff
path: root/gnu/packages/enlightenment.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/enlightenment.scm')
-rw-r--r--gnu/packages/enlightenment.scm145
1 files changed, 74 insertions, 71 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 8dae5f40d3..64d8945f8e 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -1,10 +1,11 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
 ;;; Copyright © 2015 Daniel Pimentel <d4n1@member.fsf.org>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015-2023 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Nikita <nikita@n0.is>
 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Timo Eisenmann <eisenmann@fn.de>
+;;; Copyright © 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -26,7 +27,6 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix utils)
-  #:use-module (guix build-system gnu)
   #:use-module (guix build-system meson)
   #:use-module (guix build-system python)
   #:use-module (gnu packages)
@@ -82,63 +82,67 @@
                 "05bxc58hj0z6pkp6yy5cmy1lc575q0nrbr5lxr6z8d4kznh3my6r"))))
     (build-system meson-build-system)
     (native-inputs
-     `(("check" ,check)
-       ("gettext" ,gettext-minimal)
-       ("pkg-config" ,pkg-config)
-       ("python" ,python)))
+     (list check
+           gettext-minimal
+           pkg-config
+           python))
     (inputs
-     `(("curl" ,curl)
-       ("giflib" ,giflib)
-       ("gstreamer" ,gstreamer)
-       ("gst-plugins-base" ,gst-plugins-base)
-       ("ibus" ,ibus)
-       ("mesa" ,mesa)
-       ("libraw" ,libraw)
-       ("librsvg" ,(librsvg-for-system))
-       ("libspectre" ,libspectre)
-       ("libtiff" ,libtiff)
-       ("libxau" ,libxau)
-       ("libxcomposite" ,libxcomposite)
-       ("libxcursor" ,libxcursor)
-       ("libxdamage" ,libxdamage)
-       ("libxdmcp" ,libxdmcp)
-       ("libxext" ,libxext)
-       ("libxi" ,libxi)
-       ("libxfixes" ,libxfixes)
-       ("libxinerama" ,libxinerama)
-       ("libxrandr" ,libxrandr)
-       ("libxrender" ,libxrender)
-       ("libxss" ,libxscrnsaver)
-       ("libxtst" ,libxtst)
-       ("libwebp" ,libwebp)
-       ("openjpeg" ,openjpeg)
-       ("poppler" ,poppler)
-       ("util-linux" ,util-linux "lib")
-       ("wayland-protocols" ,wayland-protocols)))
+     (list curl
+           giflib
+           gstreamer
+           gst-plugins-base
+           ibus-minimal
+           mesa
+           libraw
+           (librsvg-for-system)
+           libspectre
+           libtiff
+           libxau
+           libxcomposite
+           libxcursor
+           libxdamage
+           libxdmcp
+           libxext
+           libxi
+           libxfixes
+           libxinerama
+           libxrandr
+           libxrender
+           libxscrnsaver
+           libxtst
+           libwebp
+           openjpeg
+           poppler
+           `(,util-linux "lib")
+           wayland-protocols))
     (propagated-inputs
      ;; All these inputs are in package config files in section
      ;; Requires.private.
-     `(("dbus" ,dbus)
-       ("elogind" ,elogind)
-       ("eudev" ,eudev)
-       ("fontconfig" ,fontconfig)
-       ("freetype" ,freetype)
-       ("fribidi" ,fribidi)
-       ("glib" ,glib)
-       ("harfbuzz" ,harfbuzz)
-       ("libinput" ,libinput-minimal)
-       ("libjpeg" ,libjpeg-turbo)
-       ("libsndfile" ,libsndfile)
-       ("libpng" ,libpng)
-       ("libunwind" ,libunwind)
-       ("libx11" ,libx11)
-       ("libxkbcommon" ,libxkbcommon)
-       ("luajit" ,luajit)
-       ("lz4" ,lz4)
-       ("openssl" ,openssl)
-       ("pulseaudio" ,pulseaudio)
-       ("wayland" ,wayland)
-       ("zlib" ,zlib)))
+     (append
+       (list dbus
+             elogind
+             eudev
+             fontconfig
+             freetype
+             fribidi
+             glib
+             harfbuzz
+             libinput-minimal
+             libjpeg-turbo
+             libsndfile
+             libpng
+             libunwind
+             libx11
+             libxkbcommon)
+       (if (member (%current-system)
+                   (package-transitive-supported-systems luajit))
+         (list luajit)
+         (list lua-5.2))
+       (list lz4
+             openssl
+             pulseaudio
+             wayland
+             zlib)))
     (arguments
      `(#:configure-flags
        `("-Dembedded-lz4=false"
@@ -148,6 +152,10 @@
          "-Dmount-path=/run/setuid-programs/mount"
          "-Dunmount-path=/run/setuid-programs/umount"
          "-Dnetwork-backend=connman"
+         ,,@(if (member (%current-system)
+                        (package-transitive-supported-systems luajit))
+              `("-Dlua-interpreter=luajit")
+              `("-Dlua-interpreter=lua"))
          ;; For Wayland.
          "-Dwl=true"
          "-Ddrm=true")
@@ -158,22 +166,17 @@
          ;; have to wrap the outputs of efl's dependencies in those libraries.
          (add-after 'unpack 'hardcode-dynamic-libraries
            (lambda* (#:key inputs #:allow-other-keys)
-             (let ((curl    (assoc-ref inputs "curl"))
-                   (pulse   (assoc-ref inputs "pulseaudio"))
-                   (sndfile (assoc-ref inputs "libsndfile"))
-                   (elogind (assoc-ref inputs "elogind"))
-                   (lib     "/lib/"))
-               (substitute* "src/lib/ecore_con/ecore_con_url_curl.c"
-                 (("libcurl.so.?" libcurl) ; libcurl.so.[45]
-                  (string-append curl lib libcurl)))
-               (substitute* "src/lib/ecore_audio/ecore_audio.c"
-                 (("libpulse.so.0" libpulse)
-                  (string-append pulse lib libpulse))
-                 (("libsndfile.so.1" libsnd)
-                  (string-append sndfile lib libsnd)))
-               (substitute* "src/lib/elput/elput_logind.c"
-                 (("libelogind.so.0" libelogind)
-                  (string-append elogind "/lib/" libelogind))))))
+             (substitute* "src/lib/ecore_con/ecore_con_url_curl.c"
+               (("libcurl.so.4")
+                (search-input-file inputs "lib/libcurl.so.4")))
+             (substitute* "src/lib/ecore_audio/ecore_audio.c"
+               (("libpulse.so.0")
+                (search-input-file inputs "lib/libpulse.so.0"))
+               (("libsndfile.so.1")
+                (search-input-file inputs "lib/libsndfile.so.1")))
+             (substitute* "src/lib/elput/elput_logind.c"
+               (("libelogind.so.0")
+                (search-input-file inputs "lib/libelogind.so.0")))))
          (add-after 'unpack 'fix-install-paths
            (lambda _
              (substitute* "dbus-services/meson.build"