summary refs log tree commit diff
path: root/gnu/packages/ftp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ftp.scm')
-rw-r--r--gnu/packages/ftp.scm26
1 files changed, 20 insertions, 6 deletions
diff --git a/gnu/packages/ftp.scm b/gnu/packages/ftp.scm
index 9f4e4fc1c3..340489f7e5 100644
--- a/gnu/packages/ftp.scm
+++ b/gnu/packages/ftp.scm
@@ -2,7 +2,7 @@
 ;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -173,7 +173,7 @@ as required.")
 (define-public libfilezilla
   (package
     (name "libfilezilla")
-    (version "0.11.1")
+    (version "0.11.2")
     (source
      (origin
        (method url-fetch)
@@ -181,7 +181,7 @@ as required.")
                            name "/" name "-" version ".tar.bz2"))
        (sha256
         (base32
-         "1xv4is3zaz66h6iblj9pikapsjasjcbxx31bhkgn62xdq1sadfpc"))))
+         "0wl42yxrha633dbh1vcbhrpsd7sv4zwskbmlpx549ygnzi39krcn"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("cppunit" ,cppunit)
@@ -190,13 +190,27 @@ as required.")
     (synopsis "Cross-platform C++ library used by Filezilla client")
     (description
      "This package provides some basic functionality to build high-performing,
-platform-independent programs.")
+platform-independent programs.
+
+Some of the highlights include:
+@itemize
+@item
+A type-safe, multi-threaded event system that's simple to use yet efficient.
+@item
+Timers for periodic events.
+@item
+A @code{datetime} class that not only tracks timestamp but also their accuracy,
+which simplifies dealing with timestamps originating from different sources.
+@item
+Simple process handling for spawning child processes with redirected input and
+output.
+@end itemize\n")
     (license gpl2+)))
 
 (define-public filezilla
   (package
     (name "filezilla")
-    (version "3.27.1")
+    (version "3.29.0")
     (source
      (origin
        (method url-fetch)
@@ -205,7 +219,7 @@ platform-independent programs.")
                            "/FileZilla_" version "_src" ".tar.bz2"))
        (sha256
         (base32
-         "14lsplbp9fy7lk6cpwi3aj6jskz4j82h67x0fik82z1bns0zm2a3"))))
+         "0najf2w6p5j4qc8jmglx6j63mph749s5p90lz2nkmwwwy5sfvlga"))))
     (build-system gnu-build-system)
     (arguments
       ;; Don't let filezilla phone home to check for updates.