summary refs log tree commit diff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index e352cff5f9..a8b74a3632 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1182,6 +1182,21 @@ provides the GNU compiler for the Go programming language.")
        (substitute-keyword-arguments (package-arguments gccgo)
          ((#:phases phases)
           #~(modify-phases #$phases
+              #$@(if (version>=? (package-version gccgo) "12.0")
+                     #~((add-after 'unpack 'adjust-libgo-dependencies
+                          (lambda _
+                            (substitute* "Makefile.in"
+                              ;; libgo.la depends on libbacktrace.la but the
+                              ;; current dependency rules don't have libbacktrace
+                              ;; building early enough for libgo.  When built
+                              ;; with more than 1 core this issue doesn't appear.
+                              ;; see commit 5fee5ec362f7a243f459e6378fd49dfc89dc9fb5.
+                              (("all-target-libgo: maybe-all-target-libffi")
+                               (string-append
+                                 "all-target-libgo: maybe-all-target-libbacktrace\n"
+                                 "all-target-libgo: maybe-all-target-libffi\n"
+                                 "all-target-libgo: maybe-all-target-libatomic"))))))
+                     #~())
               (add-after 'install 'wrap-go-with-tool-path
                 (lambda* (#:key outputs #:allow-other-keys)
                   (let* ((out (assoc-ref outputs "out"))