summary refs log tree commit diff
path: root/gnu/packages/gdb.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gdb.scm')
-rw-r--r--gnu/packages/gdb.scm23
1 files changed, 9 insertions, 14 deletions
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index c01c65ce20..79fc49f5ff 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -40,17 +40,18 @@
   #:use-module (guix build-system gnu)
   #:use-module (srfi srfi-1))
 
-(define-public gdb-9.1
+(define-public gdb-9.2
   (package
     (name "gdb")
-    (version "9.1")
+    (version "9.2")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/gdb/gdb-"
                                  version ".tar.xz"))
+             (patches (search-patches "gdb-hurd.patch"))
              (sha256
               (base32
-               "0dqp1p7w836iwijg1zb4a784n0j4pyjiw5v6h8fg5lpx6b40x7k9"))))
+               "0mf5fn8v937qwnal4ykn3ji1y2sxk0fa1yfqi679hxmpg6pdf31n"))))
 
     (build-system gnu-build-system)
     (arguments
@@ -70,20 +71,14 @@
                      #t))
                   (add-after
                    'install 'remove-libs-already-in-binutils
-                   (lambda* (#:key inputs outputs
-                             ;; TODO: Inline the native-inputs addition and
-                             ;; below usage in the next rebuild cycle.
-                             ,@(if (%current-target-system)
-                                   '(native-inputs)
-                                   '())
+                   (lambda* (#:key native-inputs inputs outputs
                              #:allow-other-keys)
                      ;; Like Binutils, GDB installs libbfd, libopcodes, etc.
                      ;; However, this leads to collisions when both are
                      ;; installed, and really is none of its business,
                      ;; conceptually.  So remove them.
-                     (let* ((binutils ,@(if (%current-target-system)
-                                            '((assoc-ref native-inputs "binutils"))
-                                            '((assoc-ref inputs "binutils"))))
+                     (let* ((binutils (or (assoc-ref inputs "binutils")
+                                          (assoc-ref native-inputs "binutils")))
                             (out      (assoc-ref outputs "out"))
                             (files1   (with-directory-excursion binutils
                                         (append (find-files "lib")
@@ -137,7 +132,7 @@ written in C, C++, Ada, Objective-C, Pascal and more.")
 ;; <https://bugs.gnu.org/37810>.
 (define-public gdb-8.2
   (package
-    (inherit gdb-9.1)
+    (inherit gdb-9.2)
     (version "8.2.1")
     (source (origin
               (method url-fetch)
@@ -150,7 +145,7 @@ written in C, C++, Ada, Objective-C, Pascal and more.")
 (define-public gdb
   ;; This is the fixed version that packages depend on.  Update it rarely
   ;; enough to avoid massive rebuilds.
-  gdb-9.1)
+  gdb-9.2)
 
 (define-public gdb-10
   (package