summary refs log tree commit diff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 1337e8f20b..25805fe2e5 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -8,7 +8,7 @@
 ;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
 ;;; Copyright © 2018, 2019, 2020, 2021 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2019-2023 Guillaume Le Vaillant <glv@posteo.net>
-;;; Copyright © 2019-2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019-2023 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2019, 2021 Wiktor Żelazny <wzelazny@vurv.cz>
 ;;; Copyright © 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2020, 2022 Marius Bakke <marius@gnu.org>
@@ -1651,10 +1651,11 @@ map display.  Downloads map data from a number of websites, including
                      (url "https://github.com/opengribs/XyGrib")
                      (commit (string-append "v" version))))
               (file-name (git-file-name name version))
-              (patches (search-patches "xygrib-fix-finding-data.patch"))
               (sha256
                (base32
                 "0xzsm8pr0zjk3f8j880fg5n82jyxn8xf1330qmmq1fqv7rsrg9ia"))
+              (patches (search-patches "xygrib-fix-finding-data.patch"
+                                       "xygrib-newer-proj.patch"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -1663,11 +1664,13 @@ map display.  Downloads map data from a number of websites, including
                   ;; Upstream link: https://github.com/opengribs/XyGrib/pull/255
                   (substitute* "src/SkewT.h"
                     (("QMessageBox>") "QMessageBox>\n#include <QPainterPath>"))
-                  #t))))
+                  ;; Accept newer versions of openjpeg
+                  ;; https://github.com/opengribs/XyGrib/pull/298
+                  (substitute* "CMakeLists.txt"
+                    (("openjpeg-2.4") "openjpeg-2.5 openjpeg-2.4"))))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags (list "-DGNU_PACKAGE=ON")
-
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-directories
@@ -1693,7 +1696,7 @@ map display.  Downloads map data from a number of websites, including
            libnova
            libpng
            openjpeg
-           proj-7
+           proj
            qtbase-5
            zlib))
     (native-search-paths