summary refs log tree commit diff
path: root/gnu/packages/gettext.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gettext.scm')
-rw-r--r--gnu/packages/gettext.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/gettext.scm b/gnu/packages/gettext.scm
index 114d8cf7af..b3dd844147 100644
--- a/gnu/packages/gettext.scm
+++ b/gnu/packages/gettext.scm
@@ -133,10 +133,7 @@
                        #t)))))
 
        ;; When tests fail, we want to know the details.
-       #:make-flags #~'("VERBOSE=yes"
-                        #$@(if (target-hurd?)
-                               '("XFAIL_TESTS=test-perror2")
-                               '()))))
+       #:make-flags #~'("VERBOSE=yes")))
     (home-page "https://www.gnu.org/software/gettext/")
     (synopsis
      "Tools and documentation for translation (used to build other packages)")
@@ -282,7 +279,14 @@ from Markdown files.")
           (add-before 'check 'disable-failing-tests
             (lambda _
               ;; FIXME: fails despite of importing SGMLS
-              (delete-file "t/fmt-sgml.t"))))))
+              (delete-file "t/fmt-sgml.t")))
+          #$@(if (system-hurd?)
+                 #~((add-after 'unpack 'skip-tests/hurd
+                      (lambda _
+                        (delete-file "t/cfg-multi.t")
+                        (delete-file "t/cfg-single.t")
+                        (delete-file "t/cfg-split.t"))))
+                 #~()))))
     (native-inputs
      (list gettext-minimal
            perl-module-build
@@ -292,7 +296,7 @@ from Markdown files.")
            ;; For tests.
            docbook-xml-4.1.2
            perl-test-pod
-           texlive-tiny))
+           (texlive-updmap.cfg)))
     (inputs
      (list bash-minimal
            perl-gettext