summary refs log tree commit diff
path: root/gnu/packages/gnupg.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnupg.scm')
-rw-r--r--gnu/packages/gnupg.scm32
1 files changed, 27 insertions, 5 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 171eea6600..9a02635ec1 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -346,11 +346,33 @@ compatible to GNU Pth.")
            zlib))
     (arguments
      (list
-      #:configure-flags #~'(;; Otherwise, the test suite looks for the `gpg`
-                            ;; executable in its installation directory in
-                            ;; /gnu/store before it has been installed.
-                            "--enable-gnupg-builddir-envvar"
-                            "--enable-all-tests")
+      #:configure-flags
+      ;; Always use quasiquote on the next core-updates cycle.
+      #~(#$(if (%current-target-system)
+               #~quasiquote
+               #~quote)
+         (#$@(if (%current-target-system)
+                 #~(,(string-append
+                      "--with-libgpg-error-prefix="
+                      #$(this-package-input "libgpg-error"))
+                    ,(string-append
+                      "--with-libgcrypt-prefix="
+                      #$(this-package-input "libgcrypt"))
+                    ,(string-append
+                      "--with-libassuan-prefix="
+                      #$(this-package-input "libassuan"))
+                    ,(string-append
+                      "--with-ksba-prefix="
+                      #$(this-package-input "libksba"))
+                    ,(string-append
+                      "--with-npth-prefix="
+                      #$(this-package-input "npth")))
+                 #~())
+          ;; Otherwise, the test suite looks for the `gpg`
+          ;; executable in its installation directory in
+          ;; /gnu/store before it has been installed.
+          "--enable-gnupg-builddir-envvar"
+          "--enable-all-tests"))
       #:phases
       #~(modify-phases %standard-phases
           (add-before 'configure 'patch-paths