summary refs log tree commit diff
path: root/gnu/packages/golang-build.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-build.scm')
-rw-r--r--gnu/packages/golang-build.scm29
1 files changed, 1 insertions, 28 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index bccacf59f4..d69746a9be 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -293,36 +293,9 @@ addition to the ones provided by the language and “sync” and “sync/atomic
 packages.")
       (license license:bsd-3))))
 
-(define-public go-golang.org-x-sync-errgroup
-  (let ((commit "cd5d95a43a6e21273425c7ae415d3df9ea832eeb")
-        (revision "0"))
-    (package
-      (name "go-golang.org-x-sync-errgroup")
-      (version (git-version "0.0.0" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://go.googlesource.com/sync")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32 "1nqkyz2y1qvqcma52ijh02s8aiqmkfb95j08f6zcjhbga3ds6hds"))))
-      (build-system go-build-system)
-      (arguments
-       '(#:import-path "golang.org/x/sync/errgroup"
-         #:unpack-path "golang.org/x/sync"))
-      (home-page "https://godoc.org/golang.org/x/sync/errgroup")
-      (synopsis "Synchronization, error propagation, and Context cancellation
-for groups of goroutines working on subtasks of a common task")
-      (description "This package provides synchronization, error
-propagation, and Context cancellation for groups of goroutines working on
-subtasks of a common task.")
-      (license license:bsd-3))))
-
 (define-public go-golang.org-x-sync-semaphore
   (package
-    (inherit go-golang.org-x-sync-errgroup)
+    (inherit go-golang-org-x-sync)
     (name "go-golang.org-x-sync-semaphore")
     (arguments
      '(#:import-path "golang.org/x/sync/semaphore"