summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm35
1 files changed, 0 insertions, 35 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index effe3e7854..04751b6a79 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1311,41 +1311,6 @@ networks where it would otherwise be blocked or heavily throttled.")
 not included in the Go standard library.")
       (license license:asl2.0))))
 
-(define-public go-github-com-jacobsa-ogletest
-  (let ((commit "80d50a735a1108a2aeb7abc4a988d183f20c5292")
-        (revision "0"))
-    (package
-      (name "go-github-com-jacobsa-ogletest")
-      (version (git-version "0.0.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/jacobsa/ogletest")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "1lbwbxzr75g65q07ry5k4kglxqs3ym7xkvqznzm55rm3qk76v83r"))))
-      (build-system go-build-system)
-      (arguments
-       '(#:import-path "github.com/jacobsa/ogletest"
-         ;; These tests should be made working
-         #:tests? #f))
-      (native-inputs (list
-                      go-github-com-jacobsa-oglematchers
-                      go-github-com-jacobsa-oglemock
-                      go-github-com-jacobsa-reqtrace
-                      go-golang-org-x-net))
-      (home-page "https://github.com/jacobsa/ogletest")
-      (synopsis "Expressive unit tests")
-      (description
-       "Package ogletest provides a framework for writing expressive unit tests.  It
-integrates with the builtin testing package, so it works with the gotest
-command.  Unlike the testing package which offers only basic capabilities for
-signalling failures, it offers ways to express expectations and get nice failure
-messages automatically.")
-      (license license:asl2.0))))
-
 (define-public go-github-com-jacobsa-reqtrace
   (let ((commit "245c9e0234cb2ad542483a336324e982f1a22934")
         (revision "0"))