summary refs log tree commit diff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7daeaa1c86..50a73a1ae3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1264,7 +1264,14 @@ cluster segmentation algorithm.")
          (sha256
           (base32 "0hb4b1668516a4gv8avmflr565b6c1h93phdb068hcjxxj8767ba"))))
       (build-system go-build-system)
-      (arguments `(#:import-path "github.com/avast/retry-go"))
+      (arguments
+       (list
+        #:import-path "github.com/avast/retry-go"
+        #:phases #~(modify-phases %standard-phases
+                     (add-after 'unpack 'remove-examples
+                       (lambda* (#:key import-path #:allow-other-keys)
+                         (delete-file-recursively
+                          (string-append "src/" import-path "/examples")))))))
       (propagated-inputs (list go-github-com-stretchr-testify))
       (home-page "https://github.com/avast/retry-go")
       (synopsis "Simple golang library for retry mechanism")