summary refs log tree commit diff
path: root/gnu/packages/graphviz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/graphviz.scm')
-rw-r--r--gnu/packages/graphviz.scm24
1 files changed, 9 insertions, 15 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 30dd6d3405..b91c365e3c 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -379,22 +379,16 @@ graphs in Graphviz's DOT language, written in pure Python.")
                         ;; (see:
                         ;; https://github.com/kjellmf/dot2tex/issues/94).
                         "-k" "not test_semicolon")))))))
-    (native-inputs (list python-pytest))
+    (native-inputs
+     (list python-pytest
+           (texlive-updmap.cfg
+            (list texlive-pgf
+                  texlive-preview
+                  texlive-pstricks
+                  texlive-xcolor
+                  texlive-xkeyval))))
     (inputs (list graphviz))
-    (propagated-inputs
-     (list python-pyparsing
-           ;; These TeX dependencies are propagated to make it easier to build
-           ;; the resulting generated TeX files, which \usepackage them.
-           texlive-bin
-           texlive-amsmath
-           texlive-graphics
-           texlive-latex-geometry
-           texlive-latex-base
-           texlive-latex-preview
-           texlive-latex-xkeyval
-           texlive-pgf
-           texlive-pstricks
-           texlive-xcolor))
+    (propagated-inputs (list python-pyparsing))
     (home-page "https://github.com/kjellmf/dot2tex")
     (synopsis "Graphviz to LaTeX converter")
     (description