summary refs log tree commit diff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 58625be073..6ebd8c399b 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -43,10 +43,10 @@
        (base32
         "0c0irk85jd2cihm5pmf4zxhlpg08qpxjcqv1l9qn2n3h2gsaj2lf"))))
     (build-system gnu-build-system)
-    (inputs
+    (inputs `(("glib" ,glib)))
+    (native-inputs
      `(("bison" ,bison)
        ("flex" ,flex)
-       ("glib" ,glib)
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)
        ("python-wrapper" ,python-wrapper)))
@@ -82,10 +82,10 @@ This package provides the core library and elements.")
               (search-patch "gstreamer-0.10-silly-test.patch")))))
     (propagated-inputs
      `(("libxml2" ,libxml2)))
-    (inputs
+    (inputs `(("glib" ,glib)))
+    (native-inputs
      `(("bison" ,bison)
        ("flex" ,flex)
-       ("glib" ,glib)
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)
        ("python" ,python-2)))))
@@ -106,9 +106,10 @@ This package provides the core library and elements.")
     ;; FIXME: Add more dependencies for further plugins.
     (inputs
      `(("glib" ,glib)
-       ("gstreamer" ,gstreamer)
-       ("pkg-config" ,pkg-config)
-       ("python-wrapper" ,python-wrapper)))
+       ("gstreamer" ,gstreamer)))
+    (native-inputs
+      `(("pkg-config" ,pkg-config)
+        ("python-wrapper" ,python-wrapper)))
     (arguments
      `(#:tests? #f))
       ;; All tests pass except for one:
@@ -147,6 +148,7 @@ This package provides an essential exemplary set of elements.")
         "0jp6hjlra98cnkal4n6bdmr577q8mcyp3c08s3a02c4hjhw5rr0z"))))
     (inputs
      `(("glib" ,glib)
-       ("gstreamer" ,gstreamer-0.10)
-       ("pkg-config" ,pkg-config)
+       ("gstreamer" ,gstreamer-0.10)))
+    (native-inputs
+      `(("pkg-config" ,pkg-config)
        ("python" ,python-2)))))