summary refs log tree commit diff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 1655b88cb0..d6c50ade71 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -7211,11 +7211,11 @@ compiler versions.")
     (build-system haskell-build-system)
     (arguments
      `(#:configure-flags `("--flags=system-libyaml")
-       #:extra-directories ("libyaml")))
+       #:extra-directories ("libyaml+static")))
     (inputs
      `(("ghc-conduit" ,ghc-conduit)
        ("ghc-resourcet" ,ghc-resourcet)
-       ("libyaml" ,libyaml)))
+       ("libyaml+static" ,libyaml+static)))
     (home-page "https://github.com/snoyberg/yaml#readme")
     (synopsis "Low-level, streaming YAML interface.")
     (description "This package provides a Haskell wrapper over the
@@ -9581,6 +9581,7 @@ getDataFileName name = do
          ("pandoc" ,pandoc "lib")
          ,@all-static-inputs
          ,@direct-inputs)))
+    (outputs '("out" "lib" "static" "doc"))
     (synopsis "Pandoc filter for bibliographic references")))
 
 (define-public ghc-pandoc-types