summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 6b2c86fec4..62815efbb1 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1271,8 +1271,11 @@ interactive environment for the functional language Haskell.")
            ;; next rebuild. Note that they are required for GHC 8.10 and 9.2.
            #$@(if (string-prefix? "i686" (or (%current-target-system)
                                              (%current-system)))
-               #~((add-after 'skip-failing-tests-i686 'skip-failing-tests-i686-cuirass
+               #~((add-after 'skip-failing-tests-i686 'skip-more-failing-tests-i686
                     (lambda _
+                      (substitute* '("testsuite/tests/profiling/should_run/all.T")
+                        (("test\\('T11627a', \\[ ")
+                         "test('T11627a', [ when(arch('i386'), skip), "))
                       (substitute* '("testsuite/driver/testlib.py")
                         ((".*changes being made to the file will invalidate the code signature.*")
                          "")