summary refs log tree commit diff
path: root/gnu/packages/julia.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/julia.scm')
-rw-r--r--gnu/packages/julia.scm265
1 files changed, 119 insertions, 146 deletions
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index 9f3ef031c3..d35901eadb 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2021, 2022 Jean-Baptiste Volatier <jbv@pm.me>
 ;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Akira Kyle <akira@akirakyle.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -61,7 +62,7 @@
   (package
     (inherit libunwind)
     (name "libunwind-julia")
-    (version "1.3.1")
+    (version "1.5.0")
     (source
      (origin
        (method url-fetch)
@@ -69,31 +70,27 @@
                            version ".tar.gz"))
        (sha256
         (base32
-         "1y0l08k6ak1mqbfj6accf9s5686kljwgsl4vcqpxzk5n74wpm6a3"))
+         "05qhzcg1xag3l5m3c805np6k342gc0f3g087b7g16jidv59pccwh"))
        (patches
-        (append
-            ;; Fix linker issue for i686-linux because GCC10 changed default
-            ;; (see '-fno-common' option).
-            (search-patches "libunwind-julia-fix-GCC10-fno-common.patch")
-            (list
-             (julia-patch "libunwind-prefer-extbl"
-                          "0lr4dafw8qyfh8sw8hhbwkql1dlhqv8px7k81y2l20hhxfgnh2m1")
-             (julia-patch "libunwind-static-arm"
-                          "1jk3bmiw61ypcchqkk1fyg5wh8wpggk574wxyfyaic870zh3lhgq")
-             (julia-patch "libunwind-cfa-rsp"
-                          "1aswjhvysahhldbzh1afbf0hsjxrvs6xidsz2i7s1cjkjbdiia1z"))))))
+         (list
+           (julia-patch "libunwind-prefer-extbl"
+                        "0pf3lsq6zxlmqn86lk4fcj1xwdan9gbxyabrwgxcb59p8jjwsl8r")
+           (julia-patch "libunwind-static-arm"
+                        "1jk3bmiw61ypcchqkk1fyg5wh8wpggk574wxyfyaic870zh3lhgq")
+           (julia-patch "libunwind-cfa-rsp"
+                        "0qs5b1h5lsr5qakkv6sddgy5ghlxpjrn2jiqcvg7bkczy24klr6j")))))
     (arguments
      (substitute-keyword-arguments (package-arguments libunwind)
        ;; Skip tests on this older and patched version of libunwind.
        ((#:tests? _ #t) #f)))
-    (home-page "https://github.com/JuliaLang/tree/master/deps/")))
+    (home-page "https://github.com/JuliaLang/julia/tree/master/deps/")))
 
 (define (julia-patch-url version name)
   (string-append "https://raw.githubusercontent.com/JuliaLang/julia/v" version
                  "/deps/patches/" name ".patch"))
 
 (define-public (julia-patch name sha)
-  (let ((version "1.6.1"))
+  (let ((version "1.8.2"))
     (origin (method url-fetch)
             (uri (julia-patch-url version name))
             (sha256 (base32 sha))
@@ -143,7 +140,7 @@ libraries.  It is also a bit like @code{ldd} and @code{otool -L}.")
 (define-public julia
   (package
     (name "julia")
-    (version "1.6.7")
+    (version "1.8.3")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -151,10 +148,8 @@ libraries.  It is also a bit like @code{ldd} and @code{otool -L}.")
                     version "/julia-" version ".tar.gz"))
               (sha256
                (base32
-                "0q9xgdpvdkskpzl294w215f6c15c5jk276c9dah5f5w4np3ivbvl"))
-              (patches
-               (search-patches "julia-SOURCE_DATE_EPOCH-mtime.patch"
-                               "julia-allow-parallel-build.patch"))))
+                "0jf8dr5j7y8cjnr65kn38xps5h9m2qvi8g1yd8qgiip5r87ld3ad"))
+              (patches (search-patches "julia-SOURCE_DATE_EPOCH-mtime.patch"))))
     (build-system gnu-build-system)
     (arguments
      `(#:test-target "test"
@@ -164,7 +159,8 @@ libraries.  It is also a bit like @code{ldd} and @code{otool -L}.")
 
        ;; The test suite takes many times longer than building and
        ;; can easily fail on smaller machines when they run out of memory.
-       #:tests? ,(not (target-aarch64?))
+       #:tests? ,(not (or (%current-target-system)
+                          (target-aarch64?)))
 
        ;; Do not strip binaries to keep support for full backtraces.
        ;; See https://github.com/JuliaLang/julia/issues/17831
@@ -187,7 +183,8 @@ libraries.  It is also a bit like @code{ldd} and @code{otool -L}.")
                                        '("curl" "dsfmt"
                                          "gmp" "lapack"
                                          "libssh2" "libnghttp2" "libgit2"
-                                         "mbedtls" "mpfr"
+                                         "libblastrampoline"
+                                         "mbedtls-apache" "mpfr"
                                          "openblas" "openlibm" "pcre2"
                                          "suitesparse" "gfortran:lib"))
                                   ":"))))
@@ -201,66 +198,31 @@ libraries.  It is also a bit like @code{ldd} and @code{otool -L}.")
                 (string-append line "\n"))
                (("src ui doc deps")
                 "src ui deps"))))
-         (add-after 'unpack 'use-system-libwhich
-           (lambda* (#:key inputs #:allow-other-keys)
-             ;; don't build it
-             (substitute* "deps/Makefile"
-               (("DEP_LIBS \\+= libwhich") ""))
-             ;; call our version
-             (substitute* "base/Makefile"
-               (("\\$\\$\\(build_depsbindir\\)/libwhich")
-                (search-input-file inputs "/bin/libwhich")))))
          (add-after 'unpack 'activate-gnu-source-for-loader
            (lambda _
              (substitute* "cli/Makefile"
                (("LOADER_CFLAGS =") "LOADER_CFLAGS = -D_GNU_SOURCE"))))
-         (add-after 'unpack 'change-number-of-precompile-statements
-           (lambda _
-             ;; Remove nss-certs drops the number of statements below 1200,
-             ;; causing the build to fail prematurely.
-             (substitute* "contrib/generate_precompile.jl"
-               (("1200") "1100"))))
-         ;; For some reason libquadmath is unavailable on this architecture.
+         ;; libquadmath is not available on all architectures.
          ;; https://github.com/JuliaLang/julia/issues/41613
-         ,@(if (target-aarch64?)
-             '((add-after 'unpack 'drop-libquadmath-on-aarch64
-                 (lambda _
-                   (substitute* '("contrib/fixup-libgfortran.sh"
-                                  "deps/csl.mk"
-                                  "base/Makefile")
-                     ((".*libquadmath.*") ""))
-                   (substitute* "Makefile"
-                     (("libquadmath ") "")))))
-             '())
+         (add-after 'unpack 'make-libquadmath-optional
+           (lambda _
+             (substitute* "base/Makefile"
+               (("libquadmath,0") "libquadmath,0,ALLOW_FAILURE"))))
          (add-before 'check 'set-home
            ;; Some tests require a home directory to be set.
            (lambda _ (setenv "HOME" "/tmp")))
          (add-before 'build 'fix-include-and-link-paths
            (lambda* (#:key inputs #:allow-other-keys)
-             ;; LIBUTF8PROC is a linker flag, not a build target.  It is
-             ;; included in the LIBFILES_* variable which is used as a
-             ;; collection of build targets and a list of libraries to link
-             ;; against.
-             (substitute* "src/flisp/Makefile"
-               (("\\$\\(BUILDDIR\\)/\\$\\(EXENAME\\)\\$\\(EXE\\): \\$\\(OBJS\\) \\$\\(LIBFILES_release\\)")
-                "$(BUILDDIR)/$(EXENAME)$(EXE): $(OBJS) $(LLT_release)")
-               (("\\$\\(BUILDDIR\\)/\\$\\(EXENAME\\)-debug$(EXE): \\$\\(DOBJS\\) \\$\\(LIBFILES_debug\\)")
-                "$(BUILDDIR)/$(EXENAME)-debug\\$\\(EXE\\): $(DOBJS) $(LLT_debug)"))
-
              ;; The REPL must be linked with libuv.
              (substitute* "cli/Makefile"
                (("JLDFLAGS \\+= ")
                 (string-append "JLDFLAGS += "
-                               (assoc-ref %build-inputs "libuv")
-                               "/lib/libuv.so ")))
-
-             (substitute* "base/Makefile"
-               (("\\$\\(build_includedir\\)/uv/errno.h")
-                (search-input-file inputs "/include/uv/errno.h")))))
+                               (assoc-ref inputs "libuv")
+                               "/lib/libuv.so ")))))
          (add-before 'build 'replace-default-shell
-           (lambda _
+           (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "base/client.jl"
-               (("/bin/sh") (which "sh")))))
+               (("/bin/sh") (search-input-file inputs "/bin/sh")))))
          (add-before 'build 'shared-objects-paths
            (lambda* (#:key inputs #:allow-other-keys)
              (let ((jlpath
@@ -273,8 +235,12 @@ libraries.  It is also a bit like @code{ldd} and @code{otool -L}.")
                    (to
                     (lambda* (pkg libname #:optional libname_jl)
                       (string-append
-                       "const " (or libname_jl libname)  "= \""
+                       "const " (or libname_jl libname)  " = \""
                        (assoc-ref inputs pkg) "/lib/" libname ".so"))))
+               (substitute* (jlpath "CompilerSupportLibraries")
+                 (((from "libgfortran"))
+                  (string-append "const libgfortran = string(\""
+                                 (search-input-file inputs "/lib/libgfortran.so"))))
                (substitute* (jlpath "dSFMT")
                  (((from "libdSFMT")) (to "dsfmt" "libdSFMT")))
                (substitute* (jlpath "GMP")
@@ -295,11 +261,9 @@ libraries.  It is also a bit like @code{ldd} and @code{otool -L}.")
                (substitute* (jlpath "MPFR")
                  (((from "libmpfr")) (to "mpfr" "libmpfr")))
                (substitute* (jlpath "MbedTLS")
-                 ;; For the newer version of mbedtls-apache:
-                 (("libmbedcrypto.so.5") "libmbedcrypto.so.6")
-                 (((from "libmbedcrypto")) (to "mbedtls" "libmbedcrypto"))
-                 (((from "libmbedtls")) (to "mbedtls" "libmbedtls"))
-                 (((from "libmbedx509")) (to "mbedtls" "libmbedx509")))
+                 (((from "libmbedcrypto")) (to "mbedtls-apache" "libmbedcrypto"))
+                 (((from "libmbedtls")) (to "mbedtls-apache" "libmbedtls"))
+                 (((from "libmbedx509")) (to "mbedtls-apache" "libmbedx509")))
                (substitute* (jlpath "nghttp2")
                  (((from "libnghttp2")) (to "libnghttp2" "libnghttp2")))
                (substitute* (jlpath "OpenBLAS")
@@ -307,7 +271,7 @@ libraries.  It is also a bit like @code{ldd} and @code{otool -L}.")
                (substitute* (jlpath "OpenLibm")
                  (((from "libopenlibm")) (to "openlibm" "libopenlibm")))
                (substitute* (jlpath "PCRE2")
-                 (((from "libpcre2")) (to "pcre2" "libpcre2" "libpcre2_8")))
+                 (((from "libpcre2_8")) (to "pcre2" "libpcre2-8" "libpcre2_8")))
                (substitute* (jlpath "SuiteSparse")
                  (((from "libamd")) (to "suitesparse" "libamd"))
                  (((from "libbtf")) (to "suitesparse" "libbtf"))
@@ -324,40 +288,36 @@ libraries.  It is also a bit like @code{ldd} and @code{otool -L}.")
                   (to "suitesparse" "libsuitesparseconfig"))
                  (((from "libumfpack")) (to "suitesparse" "libumfpack")))
                (substitute* (jlpath "Zlib")
-                 (((from "libz")) (to "zlib" "libz"))))))
+                 (((from "libz")) (to "zlib" "libz")))
+               (substitute* (jlpath "libblastrampoline")
+                 (("libblastrampoline\\.so")
+                  (search-input-file inputs "/lib/libblastrampoline.so"))))))
          (add-after 'unpack 'enable-parallel-tests
            (lambda* (#:key parallel-tests? #:allow-other-keys)
-             (setenv "JULIA_CPU_THREADS" (if parallel-tests?
-                                             (number->string (parallel-job-count))
-                                             "1"))
-             (format #t "JULIA_CPU_THREADS environment variable set to ~a~%"
-                     (getenv "JULIA_CPU_THREADS"))))
+             (when parallel-tests?
+               (setenv "JULIA_TEST_USE_MULTIPLE_WORKERS" "true"))))
          (add-after 'unpack 'adjust-test-suite
            (lambda* (#:key inputs #:allow-other-keys)
-             (let ((pcre2 (assoc-ref inputs "pcre2"))
-                   (mbedtls-apache (assoc-ref inputs "mbedtls"))
-                   (mpfr (assoc-ref inputs "mpfr"))
-                   (gmp (assoc-ref inputs "gmp"))
-                   (nghttp2 (assoc-ref inputs "libnghttp2"))
-                   (zlib (assoc-ref inputs "zlib"))
-                   (suitesparse (assoc-ref inputs "suitesparse")))
-               ;; Some tests only check to see if the input is the correct version.
-               (substitute* "stdlib/PCRE2_jll/test/runtests.jl"
-                 (("10.40.0") ,(package-version pcre2)))
-               (substitute* "stdlib/MbedTLS_jll/test/runtests.jl"
-                 (("2.24.0") ,(package-version mbedtls-apache)))
-               (substitute* "stdlib/MPFR_jll/test/runtests.jl"
-                 (("4.1.0") ,(package-version mpfr)))
-               (substitute* "stdlib/GMP_jll/test/runtests.jl"
-                 (("6.2.0") ,(package-version gmp)))
-               (substitute* "stdlib/nghttp2_jll/test/runtests.jl"
-                 (("1.41.0") ,(package-version nghttp2)))
-               (substitute* "stdlib/Zlib_jll/test/runtests.jl"
-                 (("1.2.12") ,(package-version zlib)))
-               (substitute* "stdlib/SuiteSparse_jll/test/runtests.jl"
-                 (("5004") ,(string-replace-substring
-                              (version-major+minor
-                                (package-version suitesparse)) "." "0"))))))
+             (substitute* "test/spawn.jl"
+               (("shcmd = `sh`") (string-append "shcmd = `" (which "sh") "`")))
+             ;; Some tests only check to see if the input is the correct version.
+             (substitute* "stdlib/PCRE2_jll/test/runtests.jl"
+               (("10.40.0") ,(package-version (this-package-input "pcre2"))))
+             (substitute* "stdlib/MbedTLS_jll/test/runtests.jl"
+               (("2.28.0") ,(package-version (this-package-input "mbedtls-apache"))))
+             (substitute* "stdlib/MPFR_jll/test/runtests.jl"
+               (("4.1.0") ,(package-version (this-package-input "mpfr"))))
+             (substitute* "stdlib/GMP_jll/test/runtests.jl"
+               (("6.2.1") ,(package-version (this-package-input "gmp"))))
+             (substitute* "stdlib/nghttp2_jll/test/runtests.jl"
+               (("1.48.0") ,(package-version (this-package-input "libnghttp2"))))
+             (substitute* "stdlib/Zlib_jll/test/runtests.jl"
+               (("1.2.12") ,(package-version (this-package-input "zlib"))))
+             (substitute* "stdlib/SuiteSparse_jll/test/runtests.jl"
+               (("5010") ,(string-replace-substring
+                            (version-major+minor
+                              (package-version
+                                (this-package-input "suitesparse"))) "." "0")))))
          (add-before 'check 'disable-broken-tests
            (lambda _
              ;; disabling REPL tests because they require a stdin
@@ -365,6 +325,7 @@ libraries.  It is also a bit like @code{ldd} and @code{otool -L}.")
              ;; https://github.com/JuliaLang/julia/pull/41614
              ;; https://github.com/JuliaLang/julia/issues/41156
              (substitute* "test/choosetests.jl"
+               (("\"cmdlineargs\",") "")
                (("\"precompile\",") ""))
              ;; Dates/io tests fail on master when networking is unavailable
              ;; https://github.com/JuliaLang/julia/issues/34655
@@ -376,7 +337,7 @@ using Dates: @dateformat_str, Date, DateTime, DateFormat, Time"))
                (("@test isfile\\(MozillaCACerts_jll.cacert\\)")
                 "@test_broken isfile(MozillaCACerts_jll.cacert)"))
              ;; since certificate is not present some tests are failing in network option
-             (substitute* "usr/share/julia/stdlib/v1.6/NetworkOptions/test/runtests.jl"
+             (substitute* "usr/share/julia/stdlib/v1.8/NetworkOptions/test/runtests.jl"
                (("@test isfile\\(bundled_ca_roots\\(\\)\\)")
                 "@test_broken isfile(bundled_ca_roots())")
                (("@test ispath\\(ca_roots_path\\(\\)\\)")
@@ -395,29 +356,35 @@ using Dates: @dateformat_str, Date, DateTime, DateFormat, Time"))
                ;; @test_broken cannot be used because if the test randomly
                ;; passes, then it also raises an error.
                (("@test isinf\\(log1p\\(-one\\(T\\)\\)\\)")
-                " "))))
-         (add-before 'install 'symlink-libraries
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let ((link
-                    (lambda (pkgname dir pred)
-                      (map (lambda (file)
-                             (unless (file-exists?
-                                       (string-append dir (basename file)))
-                               (symlink file (string-append dir (basename file)))))
-                           (find-files (string-append (assoc-ref inputs pkgname)
-                                                      "/lib") pred)))))
-               (link "curl" "usr/lib/" "\\.so") ; missing libpthreads libLLVM-11jl
-               (link "suitesparse" "usr/lib/julia/" "libbtf\\.so")
-               (link "suitesparse" "usr/lib/julia/" "libklu\\.so")
-               (link "suitesparse" "usr/lib/julia/" "libldl\\.so")
-               (link "suitesparse" "usr/lib/julia/" "librbio\\.so")
-               (link "gmp" "usr/lib/julia/" "libgmpxx\\.so")
-               (link "libuv" "usr/lib/julia/" "libuv\\.so")
-               (link "zlib" "usr/lib/julia/" "libz\\.so")
-               (link "libunwind" "usr/lib/julia/" "libunwind\\.so")
-               (symlink (string-append (assoc-ref inputs "p7zip") "/bin/7z")
-                        "usr/libexec/7z"))))
-         (add-after 'install 'symlink-llvm-utf8proc
+                " "))
+
+             ;; These are new test failures for 1.8:
+             ;; This test passes on some architectures and fails on others.
+             (substitute* "stdlib/LinearAlgebra/test/lu.jl"
+               (("@test String") "@test_skip String"))
+
+             (substitute* "stdlib/InteractiveUtils/test/runtests.jl"
+               (("@test !occursin\\(\"Environment")
+                "@test_broken !occursin(\"Environment")
+               (("@test  occursin\\(\"Environment")
+                "@test_broken  occursin(\"Environment"))
+             (substitute* "usr/share/julia/stdlib/v1.8/Statistics/test/runtests.jl"
+               (("@test cov\\(A") "@test_skip cov(A")
+               (("@test isfinite") "@test_skip isfinite"))
+             ;; LoadError: SuiteSparse threads test failed with nthreads == 4
+             (substitute* "usr/share/julia/stdlib/v1.8/SuiteSparse/test/runtests.jl"
+               (("Base\\.USE_GPL_LIBS") "false"))
+             ;; Got exception outside of a @test
+             ;; LinearAlgebra.LAPACKException(16)
+             ;; eliminate all the test bits.
+             (substitute* "stdlib/LinearAlgebra/test/schur.jl"
+               (("f = schur\\(A, B\\)") "f = schur(A, A)")
+               (("@test f\\.Q\\*f\\.S\\*f\\.Z'.*") "\n")
+               (("@test f\\.Q\\*f\\.T\\*f\\.Z'.*") "\n"))
+             (substitute* "test/threads.jl"
+               (("@test success") "@test_broken success"))))
+         ;; Doesn't this just mean they weren't linked correctly?
+         (add-after 'install 'symlink-missing-libraries
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
                     (link
@@ -430,8 +397,10 @@ using Dates: @dateformat_str, Date, DateTime, DateFormat, Time"))
                                                               (basename file)))))
                         (find-files (string-append (assoc-ref inputs pkgname)
                                                    "/lib") pred)))))
-               (link "llvm" "libLLVM-11jl\\.so")
-               (link "utf8proc" "libutf8proc\\.so"))))
+               (link "libunwind" "libunwind\\.so")
+               (link "llvm" "libLLVM-13jl\\.so")
+               (link "utf8proc" "libutf8proc\\.so")
+               (link "zlib" "libz\\.so"))))
          (add-after 'install 'make-wrapper
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
@@ -467,18 +436,19 @@ using Dates: @dateformat_str, Date, DateTime, DateFormat, Time"))
          "CONFIG_SHELL=bash -x"     ; needed to build bundled libraries
          "USE_BINARYBUILDER=0"
          ;; list (and order!) of "USE_SYSTEM_*" is here:
-         ;; https://github.com/JuliaLang/julia/blob/v1.6.0/Make.inc
+         ;; https://github.com/JuliaLang/julia/blob/v1.8.2/Make.inc
          "USE_SYSTEM_CSL=1"
          "USE_SYSTEM_LLVM=1"
          "USE_SYSTEM_LIBUNWIND=1"
          "USE_SYSTEM_PCRE=1"
          "USE_SYSTEM_OPENLIBM=1"
          "USE_SYSTEM_DSFMT=1"
+         "USE_SYSTEM_LIBBLASTRAMPOLINE=1"
          "USE_SYSTEM_BLAS=1"
          "USE_SYSTEM_LAPACK=1"
          "USE_SYSTEM_GMP=1"
          "USE_SYSTEM_MPFR=1"
-         "USE_SYSTEM_SUITESPARSE=1"
+         "USE_SYSTEM_LIBSUITESPARSE=1"
          "USE_SYSTEM_LIBUV=1"
          "USE_SYSTEM_UTF8PROC=1"
          "USE_SYSTEM_MBEDTLS=1"
@@ -487,27 +457,29 @@ using Dates: @dateformat_str, Date, DateTime, DateFormat, Time"))
          "USE_SYSTEM_CURL=1"
          "USE_SYSTEM_LIBGIT2=1"
          "USE_SYSTEM_PATCHELF=1"
+         "USE_SYSTEM_LIBWHICH=1"
          "USE_SYSTEM_ZLIB=1"
          "USE_SYSTEM_P7ZIP=1"
 
+         "USE_LLVM_SHLIB=1"
+
          "NO_GIT=1"             ; build from release tarball.
-         "USE_BLAS64=0"         ; needed when USE_SYSTEM_BLAS=1
+         "USE_GPL_LIBS=1"       ; proudly
+
+         ,@(if (target-aarch64?)
+             `("USE_BLAS64=0")
+             '())
+
          "LIBBLAS=-lopenblas"
          "LIBBLASNAME=libopenblas"
 
-         (string-append "SUITESPARSE_INC=-I "
-                        (assoc-ref %build-inputs "suitesparse")
-                        "/include")
-         "USE_GPL_LIBS=1"       ; proudly
          (string-append "UTF8PROC_INC="
                         (assoc-ref %build-inputs "utf8proc")
                         "/include")
-         "LLVM_VER=11.0.0"
-
-         "USE_LLVM_SHLIB=1"
+         ;; Make.inc expects a static library for libuv.
          (string-append "LIBUV="
                         (assoc-ref %build-inputs "libuv")
-                        "/lib/libuv.so")
+                        "/lib/libuv.a")
          (string-append "LIBUV_INC="
                         (assoc-ref %build-inputs "libuv")
                         "/include"))))
@@ -519,20 +491,21 @@ using Dates: @dateformat_str, Date, DateTime, DateFormat, Time"))
        ("gfortran:lib" ,gfortran "lib")
        ("gmp" ,gmp)
        ("lapack" ,lapack)
-       ("libgit2" ,libgit2-1.1)
+       ("libblastrampoline" ,libblastrampoline)
+       ("libgit2" ,libgit2-1.3)
        ("libnghttp2" ,nghttp2 "lib")
        ("libssh2" ,libssh2)
        ("libunwind" ,libunwind-julia)
        ("libuv" ,libuv-julia)
        ("llvm" ,llvm-julia)
-       ("mbedtls" ,mbedtls-apache)
+       ("mbedtls-apache" ,mbedtls-apache)
        ("mpfr" ,mpfr)
        ("openblas" ,openblas)
        ("openlibm" ,openlibm)
        ("p7zip" ,p7zip)
        ("pcre2" ,pcre2)
        ("suitesparse" ,suitesparse)
-       ("utf8proc" ,utf8proc-2.6.1)
+       ("utf8proc" ,utf8proc-2.7.0)
        ("wget" ,wget)
        ("which" ,which)
        ("zlib" ,zlib)
@@ -545,7 +518,7 @@ using Dates: @dateformat_str, Date, DateTime, DateFormat, Time"))
        ("perl" ,perl)
        ("patchelf" ,patchelf)
        ("pkg-config" ,pkg-config)
-       ("python" ,python-2)))
+       ("python" ,python)))
     (native-search-paths
       (list (search-path-specification
               (variable "JULIA_LOAD_PATH")
@@ -553,8 +526,8 @@ using Dates: @dateformat_str, Date, DateTime, DateFormat, Time"))
             (search-path-specification
               (variable "JULIA_DEPOT_PATH")
               (files (list "share/julia/")))))
-    ;; Julia is not officially released for ARM and MIPS.
-    ;; See https://github.com/JuliaLang/julia/issues/10639
+    ;; Julia only officially supports some of our platforms:
+    ;; https://julialang.org/downloads/#supported_platforms
     (supported-systems '("i686-linux" "x86_64-linux" "aarch64-linux"))
     (home-page "https://julialang.org/")
     (synopsis "High-performance dynamic language for technical computing")