summary refs log tree commit diff
path: root/gnu/packages/language.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/language.scm')
-rw-r--r--gnu/packages/language.scm52
1 files changed, 29 insertions, 23 deletions
diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
index 182ef2f8c2..b29ed9c013 100644
--- a/gnu/packages/language.scm
+++ b/gnu/packages/language.scm
@@ -5,6 +5,7 @@
 ;;; Copyright © 2019 Alex Vong <alexvong1995@gmail.com>
 ;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2022 Milran <milranmike@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -834,29 +835,6 @@ string can be easily inferred by a human just by reading the identifier.")
 done by Gudrun Putze-Meier.")
     (license license:perl-license)))
 
-(define* (tegaki-release-uri proj version
-                             #:optional (ext "tar.gz"))
-  (string-append "https://github.com/tegaki/tegaki/releases/download"
-                 "/v" version "/" proj "-" version "." ext))
-
-(define remove-pre-compiled-files
-  (lambda exts
-    "Return snippet for removing pre-compiled files matching one of the
-extensions in EXTS."
-    `(begin (for-each delete-file
-                      (find-files "."
-                                  (lambda (name _)
-                                    (any (cut string-suffix? <> name)
-                                         (map (cut string-append "." <>)
-                                              ',exts)))))
-            #t)))
-
-;;; modules required for the above snippet
-(define remove-pre-compiled-files-modules
-  '((guix build utils)
-    (srfi srfi-1)
-    (srfi srfi-26)))
-
 (define-public link-grammar
   (package
     (name "link-grammar")
@@ -923,3 +901,31 @@ noun phrases, verb phrases, etc.).")
 analysis (pitch, formant, intensity, ...), speech synthesis, labelling, segmenting
 and manipulation.")
     (license license:gpl2+)))
+
+(define-public libskk
+  (package
+    (name "libskk")
+    (version "1.0.5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ueno/libskk")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0y279pcgs3jrsi9vzx086xhz9jbz23dqqijp4agygc9ackp9sxy5"))))
+    (build-system gnu-build-system)
+    (native-inputs (list autoconf
+                         automake
+                         gettext-minimal
+                         gobject-introspection
+                         libtool
+                         pkg-config
+                         vala))
+    (inputs (list libgee json-glib libxkbcommon))
+    (home-page "https://github.com/ueno/libskk")
+    (synopsis "Dealing with Japanese kana-to-kanji conversion")
+    (description
+     "libskk is a library to deal with Japanese kana-to-kanji conversion method.")
+    (license license:gpl3+)))