summary refs log tree commit diff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f3e7d18627..b97315580b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -133,7 +133,13 @@
                (format #t "`ARCH' set to `~a'~%" (getenv "ARCH")))
 
              (let ((build (assoc-ref %standard-phases 'build)))
-               (and (zero? (system* "make" "allmodconfig"))
+               (and (zero? (system* "make" "defconfig"))
+                    (begin
+                      (format #t "enabling additional modules...~%")
+                      (substitute* ".config"
+                        (("^# CONFIG_CIFS.*$")
+                         "CONFIG_CIFS=m\n"))
+                      (zero? (system* "make" "oldconfig")))
 
                     ;; Call the default `build' phase so `-j' is correctly
                     ;; passed.